Problem with access to FTP server

Hi, I need some advice.

I’ve got My Cloud EX2 Ultra (OS: 2.30.193). I want MyCloud to be data warehouse. I want to send data from remote virtual machine (in automatic way) so connection between MyCloud and virtual machine has to be constant. Virtual machine has diffrent Internet network than MyCloud (it is far away from MyCloud device). The task is to make backups and size of these backups is large (several TB).

Here is my first question: What is the best way to connect between virtual machine (remote access) and MyCloud in order to send (and magazine) a large amount of data in automatic way (without action of user)? Is it FTP?

I know the access to MyCloud can be realized by Internet account or desktop application, but this is not the way I’m looking for.

MyCloud can connect to FTP server. And this is the way I’ve tried to solve the problem. But it still doesn’t work. Here is description of what I did:

  1. I set MyCloud IP as a static IP:
    1

  2. I set FTP access enabled.
    image

  3. And then i go Apps -> FTP Downloads, create a job and try to connect to remote FTP server (with account).
    When I want to choose Source Folder I see the message:

I check if my FTP port (21) is open (using https://www.yougetsignal.com/tools/open-ports/).
And it says the port is closed (even if antivirus and windows firewall are turned off).

I can add that connection using Filezilla works good. So what is the problem?
Should I set Port Forwarding on MyCloud or router?