Problem Updating WD Smartware

WD Smartware will not update. Keep getting error saying

Please help. How do I get this to update?



Are you downloading the latest version from the WD Support site or updating through the software?


Either way it’s the same error. I’ve tried updating from software. I tried downloading from the site. and I’ve tried uninstalling the software and reinstalling from the site. All ends in the same error message. What now?

@friesjh What device do you have SmartWare on? Is it a Windows, Apple or what? When you download SmartWare where do you save it? Mine is in my downloads>programs.

The Smartware is on my desktop PC which is running Windows 10. I usually download to my desktop, but I did a search of my C: drive for the file listed in the error message and it’s not on the computer. Where can I get the file it’s looking for and where do I save it?

Can anyone help with this?

I have a very similar problem. Specifically yesterday WD Smartware tried starting and crashed. On crashing a pop up window blinked something about “configuration” (went by too quickly). WD Smart been working fine for many months. Yesterday I called support and was told to re-install WD Smartware. Relevant to this thread is on installing I did get a popup error about some configuration. Could not find a configuration file I think was the error. Installation seemed to continue, no indication of failure other than it won’t work.

What I did (Windows 10 64 bit, Dell XPS 8700):
Used control panel to first repair. In this process the configuration stated 1 sec left green bar and stayed there for 15-20 sec. and then proceeded with all indication of success. On starting WD Smartware same issue. I uninstalled the three programs that com in the zip file. I then went to the WD site and downloaded the latest version again and reinstalled. As it was installing I got a similar error pop up something about configuration (again on too brief to fully read). I uninstalled all WD, ensured Windows 10 updates were all up to speed and tried it again. No Joy.

I solved my problem; solution was in a 2013 post “configuration system failed to initialize” on Windows 8 . The solution is the same for windows ten. It appears the cause was the same. I started a new topic as it was more specific than what I posted here. After a while I may delete both entries here.