Problem solved. Save my My cloud home. I can't access my device

When you try a browser is this the address you use? My Cloud Home

Yes. The page searches for the equipment, but does not find it. On the second attempt, it asks for the product code, xxx-xxx-xxx, but nothing is found.

It looks like you have known your answer already, the hard drive has failed and you can confirm this by reading the debug_logs.tar file. It is unlikely, but sometimes power OFF and ON multiple times may get the hard drive running again. Other recovery options are listed in the Knowledge base article but if you have already done the 60 second wipe, there may be little to recover.

I won this equipment. It came without the HD. I put a clean HD for testing. I’ve tried the 60 second cleaning process, but nothing happens, the lights stay on continuously. The only thing I can identify is the IP and MAC in the list of connected equipment. I cannot access any pages. The function to generate LOG also did not work.
I believe that the problem is the firmware, but I did not find any guidance on how to update its firmware by connecting directly to the computer.
Or maybe it only works with HD formatted in linux.

You need to restore the factory partitions without this new drive will not work

1 Like

You should have just said that in the first place. This process not supported by anyone, least of all WD. There are plenty of resources to read in this forum and the tools are free. You will need a disk image from an existing MCH, perhaps the one from the Russian site will work, or may be not.

I will try to carry out the procedures informed.
As soon as I have an update on the case, I’ll come back to let you know the result.
Thanks a lot for your help.

My friend, you are a genius.
I managed to do the step by step indicated.
Now my device is working again.
IP Ping works.
The doors appear.
I can access the public folder through windows explorer.
Now, I just need to be able to access it through the app or browser.
But it’s already a relief to know that there is salvation for my device.
Thank you very much.

Now I would like to know is there an interface for configuring the recovered system, or will access from now on be only through port SMB-445?
How do I fix the device’s IP now?

I am glad that everything worked out for you) Now you need to activate the account according to the wd instructions in the browser… There you link your device to your account and all the settings appear. In order for the system to find your wd you must be on the same network as the device . In your first messages before recovery, you already did it

Yes, but it doesn’t find the device. As stated in the text of the instruction file on that link with the recovery files that you sent me, when doing this procedure, access to the cloud is lost.

Look at the network settings enable network discovery on the pc disable the firewall … on win it should work on linux not sure

And I understand that you have only restored the image of the operating system and to connect to the wd cloud, you still need to restore the partitions… There is an image with markup on my link

Network discovery is enabled, firewall and antivirus disabled.
About the restoration, I did exactly as in your video.
I restored the disk image and then restored all 23 partitions one by one.
With either of the two images,

“”#0_AIO_FULL_WD Cloud Offline 1TB""
“WDMC Home (LAN ver) Disk Image (Files)”"

I can only access the public folder through port 445.
I can’t access it through the “my cloud home” app, or browser.

Then yes, everything is true… The injection is installed with root and the wd service will not work… Еще вариант DEBIAN 11 & OpenMediaVault 6 WD My Live\Book\Cloud\Cloud Mirror - 4PDA

The link to download the system is not working.
I’ve tried downloading using other browsers, but it didn’t work.

You should really read the subforums or at least search through them because the path to hacking the MCH is full of failed attempts or at least many poor and undocumented attempts that ended in failure.

The main thread is this one below and you can ask RAH-66 who is the more helpful active member working on installing Debian on the MCH.

You didn’t write what doesn’t work… If you follow the instructions then Debian 11 should work 100%. There is a problem with installing updates and OMV6 due to the fact that the Debian 11 snapshot is outdated. This is solved by manually setting the current date command, after installing Debian 11 and before installing OMV6:

After installing OMV6, be sure to configure the NTP time synchronization server in it.

“Alternative”)) download link: Install Debian on WD My Cloud home - My Cloud Home - Personal Cloud Storage / My Cloud Home Ideas - WD Community

I’m sorry if I don’t understand some procedure. I’m new to the Linux world. I will try to carry out the indicated processes. Thanks a lot for the help so far.

Well, after a few days of trying during my work breaks, I managed to install OpenMediaVoult on my MCH.
I made several attempts with the available fonts.
The only way I managed to make it work was by restoring the MCH using “#0_AIO_FULL_WD Cloud Offline 1TB” and then installing “wd-mycloud-home-debian”.
The other versions of the previous links did not work.
It’s not the latest version of the OMV, but it finally manages to resurrect my device.

Thanks to everyone who helped.
Now I need to learn more about OpenMediaVault and Linux.

1 Like