Problem on my MyBook Essential WD 2TB


im using MyBook Essential WD 2TB harddisk…it were okay last night,and the morning i wake up,the external HDD seems seem it cant detect my drive never the problem:

  1. when i click on My Computer,it seem it take longer time to view it when this HDD is connected.
  2. There is no list of my drive on My Computer.
  3. Sometimes,the drive on My Computer does appear,sometimes it dont.when it is appear,it doesnt show the “how much GB left”.it just show “Local Disk F”.
    4.and the most annoying problem is,it keep asking me to format when i unplug the usb 3.0 cable.

5.i also tried to open Disk Management.but it seem,it cant load keep saying that  “Connecting to Virtual Disk Service…” but it working fine,when i unplugged the,i assume that the problem came from this external.

Solution i tried :

  1. i try to disk check error,but it say it cant recognize the drive.=="
  2. i do also reformat my windows 7.

is there any way to retrieve my file,without having to FORMAT this external file were almost 1.5TB.sob…sob…please computer expert,help me.

It sounds like data corruption.  You may try using the drive with another PC.  If you have the same results you may try to retrieve the data using a data recovery software.

Besides recovery software try burning a Linux Live CD and boot from that and see if you can access the drive.