Problem mapping drives to mycloud shares Windows 7

After a few days, the mapped drives in Windows 7 show “disconnected” even though the Dashboard finds the mycloud and the blue light on it is on. The mapped drives can’t be reconnected until the mycloud is powered down reset. This makes it impossible to auto backup files from the PC. I have tried assigning a static IP address in my router but it doesn’t help. Restarting the PC doesn’t help. WD Smartware also can’t access the shares. Clearly a lockout problem in mycloud (2 TB, all firmware current).

Try setting a static IP on the My Cloud side. Check page 80 of the manual for more info.

Does the problem subsist when Smartware is NOT installed?

Static IP was also set on the mycloud side. No difference.

Don’t know. Can’t uninstall without losing backup.

what happens when you try to open a share that cannot reconnect? What is the error message?

There is no error message. Windows Explorer seems to search for a file (the progress bar) and doesn’t find a file. When the share is successfully mapped, clicking on the share in Windows Explorer shows the contents of the share.

Look at your router settings. Check the DHCP IP adddress range. Make sure the IP address you assigned to your NAS is outside of that range, to avoid any potential IP address conflict (unlikely, but possible).

I can’t do this on my Linksys router (EA-4500 with SmartWifi). The Connectivity page just allows setting the range of IP addresses for both DHCP and static, not static separately. I did change the mycloud static IP address to168.1.1.146 and the highest DHCP address assigned is Hopefully this might work. It may be a couple of days before I know.:smiley:

Seems to have worked. No map disconnects for several days.