Problem loading drive after failed firmware update

Hey everyone,

I’m using a 2TB MyBook Essential on a Mac. I had it password locked with the SmartWare software but decided that wasn’t necessary anymore. I removed the password protection and deleted the SmartWare files off the drive and emptied the trash. Right after that, I attempted to upgrade my firmware to During the update, I got an error saying that an error occured.

After that, my drive became unreadable and I have no idea now to solve the issue. I tried different cables, different computers and still doesn’t work. You can hear the drive spinning once I connect it but the capacity indicator lights do not come on and the Mac can’t detect a drive being connected at all. Even if I shut down the Mac the drive stays on but not spinning.

Of course, I emailed WD support 6 days ago and still didn’t get any reply. The drive contents aren’t too important so my priority is getting the drive to function rather than saving the data on it.

Any ideas on how to fix this?

If the firmware update failed there is not a lot more you can do to make it work. Try calling tech support directly.