Problem displaying pictures of movie files

I have made custom pictures for some TV series i have using photoshop and naming them the exact same name as the file.

I’ll take Fringe for exemple. 

  • I have a Folder where i have my Fringe episodes

  • Each mkv files as a jpg picture associated with it.

Problem is, i only see half of them, some are showing, some are not. And there’s no typo, all files are perfectly named.

Another problem, I have 4 mkv of Game of Thrones and after making different pictures, making the files smaller and such, it worked and i was able to display 2 out of 4 pictures for the mkv. Thing is, i just deleted these pictures from the WD TV Live’s HDD… AND THEY ARE STILL SHOWING !!

There’s something really strange going on…

The Hub internally caches thumbnails.   You’ll need to re-compile the Media Library to pick up changes.  If you’re permantently deleting things, you may need to CLEAR the media library.

or try this approach, recopied from a post of mine in an earlier thread:

Just thought I add my two cents since I have been changing thumbnails a lot.  I make them on the computer, and add them over the network share.  The only efficient and dependable way I have found to get the Hub to recognize the new thumbnails and “forget” the old ones is to do it like this:

After I’ve added the thumbnails (e.g. folder.jpg, or thumbnails named identically to videos) to the Hub using the computer, accessing the Hub as network share, then

  1. Turn off the WD using power off on the remote.

 (you don’t need to unplug or do a hard shut down, in fact this won’t work if you do because you need to access the WD as a network share)

  1. From the computer find “thumb” in directory from the .wd_tv directory in the root HUB directory. Then, delete the whole thumb directory, or navigate more surgically to find the directory you changed or even the actual thumb files. The WD regenerates them rapidly, so it’s not a hassle for me with several hundred thumbs to delete a whole directory. 

  2. Restart the WD using power on from the remote,

  3. Then immediately do a “device restart” from within the menu.  (Home --> Setup --> System --> Device Restart).  This is more like a reboot than just powering off/on with the remote. 

This seems like a lot but it’s been sure-fire for me after a lot of experimentation, with turning the unit on and off, rebuilding the library, moving directories around, looking for files in different views on the Hub, etc. It’s a lot easier than trying “easier” things over and over and/orwaiting for the HUB to get around to finding changes.

Careful though in deleting anything from the Hub, there’s no recycle or undelete function that I know of.  

John

JohnnyLamb

Thx! I will try that tonight, ill post to result later :slight_smile:

AMAZING !

It worked !

Thanks X 1000 !

@ Telimtor

Glad it worked, thanks for letting me know. 

You’re welcome.