Problem after update to 01.02.14 firmware!

Hi everybody! 

Please, I need some assist!

I’m having some issue after this update to firmware 01.02.14.

I have updated using web-interface, and after the update my MBWE can’t mount the DataVolume.

It was working perfect before the update =/

The configuration page is running and the Storage > Disk Manager says that the status is  GOOD.

But in Storage > Volume Status it says:
Volume: DataVolume
Type: Span
Usage: unknown
Size: unknown
Status: Failed (Failed to mount this volume!)

and in System Status confirm "DataVolume Usage:  Failed ”.

In Windows 7 I can see the MyBookWorld and the folders Configuration, Public, Download and System (my folder). but the only one that I can access is “Configuration”, the other 3 gives me the message “Windows cannott access…”

Do you know what is happening? why this happened if I made the update thru MBWE system?

and the main point what should I do? =/

Thank you!!

How many drives on the MBW?

If you have a single drive the unit needs to be reset

if MBW 2 try removing and putting back the drive in question

Hi Wizer!

Thank you for your reply!

It’s MBW white light single driver 1tb!

I have tried to reset a lot of times and keep the same message “Failed”.

This reset only change the configuration, seems to not effect the partition, or the code that make it work!

Do you have any other ideia of what can I do?

I tried to update manually again the FW but keep the same error =/

Thank you!


I have exactly the same problem. If I restore the unit to factory defaults, the Datavolume will come back, but only for a few hours/days. After this I have to restore again. Anybody found a solution to this?

I would love to downgrade the firmware… but this is not allowed / possible?


I understand that it might be entirely possible but will take a little effort.

  1. This chap eduardo / gist:1239075   has   a set of instructions which I followed to downgrade from the disasterous 1.02.10 debacle.  Search for the term “How to downgrade the My Book World edition firmware from 1.02.10 to 1.02.06”

  2. You’ll need to locate a previous firmware - 1.02.06 appears to have the fewest problems and is reliable.

  3. You’ll need to also need be confident enough to use PUTTY

  4. Unless the later firmwares have been worked to prevent this from working.

  5. There is a risk that you could brick the device.

  6. Follow these instructions at your own risk but my experience admittedly with the previous issue it sorted it and I’m still on 1.02.06 but I do run Twonky 7 and it works OK.

Hope this helps - I am no expert but followed the instructions Eduardo posted and it worked.