Problem acessing media server - mybook world edition

Hi guys,

So, I had a MBWE unit that was malfunctioning, so I returned it to WD for replacemente. Yesterday I got the new unit. Plugged it to the network and everything seemed fine: I could see the public and downloads shares on my mac (running lion). I accessed the control panel, and downloaded the latest firmware. Then I copied some mp3 files to the music folder, and some pics to the images folder. But when I tried to acess the music files through itunes (latest version), nothing: it would recognize the mybook as a media server (ie it would appear on the left colum) but when I clicked on it it would just show the message ‘connecting to mybook’ but would never actually complete the connection.

I then turned on my ps3 (also with the latest firmware update), and told it to look for media server on my network, to no avail… I have to say I’m pretty disapointed. My old unit, before it went awry, worked well, if a bit slow, but that was probably the routers fault. Anyway, any tips? Did I miss something in the configurations?

Thanks in advance.


Pedro Ivo

hum, guess I should add that the mybook in question is the white light version.

I believe that the latest version of itunes  has a problem with the mbwe the solution seems to be going back to an older version of itunes until itunes or wd comes out with a fix.