Problem accessing data on old MyCloud HDD

In the last episode my old MyCloud died (front led is steady red) and I wasn’t able to connecto to it. New network cable didn’t work. Reset attempts, short and long, didn’t do anything - the led remained solid red. I assumed - and hoped - this was a bad controller and the HDD is still intact. So I got a new MyCloud, connected it successfully and now I want to copy to it the content of the old one. I removed the HDD from the old MyCloud box and, using a SATA-to-USB cable connected it to the USB port of the new MyCloud, which couldn’t read it (front led went red until I disconnected it). Then I fired up my Linux (mint) installation which identified the disk as /dev/sdb. I tried to mount it using this:

sudo mkdir -p /media/usb
sudo mount -t ext4 -o defaults /dev/sdb /media/usb

and got this error:

mount: wrong fs type, bad option, bad superblock on /deb/sdb, missing codepage or helper program, or other error

What does that mean? How even can I find out if the old HDD is OK?


Not all the partitions on the drive are ext4. Most of the system partitions are ext3.

Dig out one of the ‘unbricking’ threads for details.


I tried the unbricking procedure here:

At least until step 14, as parted didn’t say anything about errors in the data partition. The drive is still dead, even with the new image. No connection, no reset, no nothing.

My question is: how to read the files after connecting it through SATA or USB to my PC?


Sorry; I really meant for you to find out details of the file formats for each of the partitions, which are described in the unbricking guides. I wasn’t suggesting you tried unbricking…

There are many partitions on that drive. To know which partition you should be looking at, I need to know what version of mycloud you have (Gen1, or Gen2). Gen1 has a firmware that says 4.xxxx for the version. Gen2 has a firmware that says 2.xxxx for the version.

From the data recovery software thread, Gen2 myclouds have the data volume on partition 2.
Bennor says that on Gen1 it is partition 4.

For the manual mount under linux, on Gen2 it would be
sudo mount -t ext4 /dev/sdb2 /some_mount_point

and on gen1 it would be:
sudo mount -t ext4 /dev/sdb4 /some_mount_point

The data recovery thread can be found here: