Problem: Acces from iPhone through local network but not through internet

I used to have access to my WD MyCloud from my iPhone through my local network at home as well as through the internet anywhere.
But somehow the access through internet doesn’t work anymore. It says that my WD MyCloud is not available, while access through my local network is fine.
What can be the problem?

Have you logged into the My Cloud Dashboard and ensured Remote Access is enabled, and that it indicates a connection has been established?

Yes I have.

If log into, can you access your My Cloud?

In your iPhone, if you see the 3-bar menu on first page of My Cloud app, then tap the 3-bar menu. Is the my cloud highlighted with a long blue bar along side it? If not, tap the My Cloud choice there to get the blue bar, and then try accessing My Cloud again.

Yes I can.

If you can log into and access your my cloud through that user portal it can access your My Cloud remotely. That would seem to indicate a problem with either the iPhone or the iPhone My Cloud app itself. Did you try or check what Mike27oct indicated about checking to ensure the My Cloud is highlighted in the app?

Is your My Cloud updated to the latest firmware? for v4.x the latest firmware is 04.04.02-105, for v2.x the latest firmware is 2.11.133.

I tried to access my My Cloud though the user portal and that worked.
Now after that I tried to access my My Cloud through my iPhone once more, and guess what: NOW IT WORKED.
Don’t ask me what did the trick. Maybe the MyCloud had to be awakened for internet access calls?
Well thank you Bennor and Mike for your help. I really appreciate it.
I hope others can benefit from this problem solution too.