Problem acceding WD MyPasport 4TB

Few months ago I bought a WD MyPasport 4TB disk, and recently, when I tried to access in Windows 10 SO, I saw the disk in the disk list, but it doesn’t specified disk usage, and when I tried to open the disk the windows freezed and never stop freezig, and when unplugged the disk the freezing state dissapear.
The disk ran properly before this situation, I tried to mount in linux system and appeared the next errors on logs:
blk_update_request: critical medium error
Buffer I/O error on xxx, logical block xxx, async page read

I tried to execute analysys of the surface and the app returns that is ok, and I tried chfdsk /f in windows but runs very slowly and never finished, for the slow speed.

I didn’t setted any password for the device.

¿Can I format he partition and recover the files with testDisk, for example? ¿or is not possible with default encryption?

1 Like

I am having the same problem since a few days ago, windows 10, my passport 4TB, windows grinds to a halt, unusable very slow when my passport 4TB plugged in, as soon as I unplug it, windows works perfectly again. I only bought it a few months ago. Cannot access files on drive.


Another topic with similar case:


Hello, I am having issues very much alike to what is described above. I have precious files on the harddrive (WD 1913B 1TB, bought a few years ago, little used, never had any issues). Tried on 3 computers, same result. I would like to fix it, hope I get help from this community. Thank you.

I’m at the same situation, and it seems that more people have been having the same problem recently, we have waiting for a response from WD.

i am facing the same problem, i have warranty but what happen to the data.

1 Like

im having identical problems with my unit