WD external harddisk cannot be read or accessed

My WD passport external hard disk is of 2 TB.
I can see the HDD shown as some local disk(not with the HDD given name) but it cannot be accessed. And windows explorer stops responding if i try to access it.

So let me summarise the points i have on my problem:

problem points:

  1. after connecting it to the device, it continuously blinks and i can hear sound that it is running inside. But in file manager, it just shows the disk name (like Local Disk H) not my harddisk name.

  2. And I cannot access it rom my computer/windows explorer(or whatever it is called)

  3. when it is connected to the device, disk management keeps on loading and does not show the results.

  4. If I open device manager, I can see my HDD there.

Thing I tried or noticed:

  1. It is not device usb port problem(i have tried on more than one device).

2.I have tried updating the driver from device manager.

  1. I also went to the properties of the HDD(which shows as local diskH and not with its actual name) but there is no error message.

  2. I tried to use a data recovery software but it is also stuck at “refreshing disk information” page and keeps loading while the HDD is connected.

If anyone has any idea on what is going on or how to fix it please let me know.
Anything would be highly appreciated.
Thank you.

1 Like

Hi,

Two persons (I included) have been having the same problems since some few days ago, I created this topic:

We are waiting for a solution or information about the possible reasons for the problem, or if exists a bug in the windows driver or similar, because I have been checking the disk in Linux and appears the information about it and partitions, without any freezzing the system, but I can’t mount the partition, I think for the encryption.

Regards,

2 Likes

Thank you for taking the time to let me know too. I will try to follow the above mentioned topic too if someone share any solution there.

Hope it gets solved somehow.

Thans again

https://support-en.wd.com/app/answers/detail/a_id/12455/h/p2 I found this tread, honestly, no time now to try, seems a bit useless but have not gone through it all so no idea. Not looking promising. Hope I am wrong.

I reviewed the post and performed all possible steps (for example, the part of Disk Management is not possible for the freezing state when the disk is connected), and I obtained the same behaviour and result.
I tested another time in Linux, and in Linux the system didn’t freezed, the disk appears in the available disks, but is not possible mount the partition for the disk encryption (I hope/think), and this behaviour say me is a possible bug with the driver or similar, but we need information form WD.