PR4100, OS5, and Twonky DLNA Server

I want to know how to get the “other” DLNA Server app I used to have on OS3 (or whatever OS I had before upgrading to OS5). I upgraded to OS5 and the “other” DLNA Server app is no longer available.

Please don’t suggest I use Plex. I don’t like it, there are limitations w/ the free version, and I don’t want to use it.

I don’t know if there are bugs with Twonky and OS5, but it is a useless app for me. There are a LOT of issues I have with it; but the four listed below are just a few that make it virtually unusable. These are isolated to Twonky. My NAS is responsive and doesn’t hang or otherwise become unusable with any of the described states/issues below.

I use Roku Media Player on my Roku device and VLC on my Amazon Fire. The issues exist for both devices. I had NO issues in the past year using the “other” DLNA app. Not one. No hang ups, no corrupted databases, no lapses in refreshing/updating, nothing. I had only occasional issues in the > 5 years I used it, all of which would be corrected by rebuilding the database (which took < 20 mins).

  1. I have to reboot Twonky via the config page at least once a day, or I cannot access my media. Occasionally, when I try w/o restarting the server everyday, my clients (Roku and Amazon Fire) both just sit and spin. They never start playing. It is unpredictable and not at all consistent (e.g., by its uptime interval), so I have to resort to restarting at least once a day. This is REALLY irritating if I am in the bedroom, wanting to watch a movie before going to sleep and the server is hung up again. I have to get out of bed and go log into the console. Occasionally, it still hangs even when it was restarted just a few hours ago (hence the “at least once a day” verbiage). I haven’t noticed it hanging w/in 4 hours of a restart. Anything > 4 hours is a ■■■■ shoot as to when (not if) it will hang. By the way, I originally thought it was indexing or some other server processing; but I have left the server in this state for up to 12 hours and it never resolves and never comes back. I have to restart it or it [apparently] remains in this perpetual hang up.

  2. I cannot play more than two songs in a row, no matter how I instigate the play. E.g., if I play the album, if I put it in random mode, if I create a playlist, etc. It will play two songs exactly, then quit. This is infuriating. I thought it was some sort of timeout happening, due to screensaver or not clicking a button on the device remote; but it isn’t. I disabled the screensavers and would keep the screen “active” by clicking info or other. Regardless, it plays two songs and stops. I thought, too, it was a client issue; but it happens on both of my devices. This has NEVER happened before I used Twonky. and doesn’t happen with Plex. I cannot even figure out a workaround. E.g., restarting right before I play music does not avoid the issue.

  3. I cannot use my clients’ “Playlist” option or it will hang Twonky EVERY SINGLE TIME. E.g., the Playlist shows things like recently accessed, recently added, etc. If I inadvertently hit this option on the client, I have to turn off, then turn on Twonky via the PR4100 Apps page. I have also tried leaving the server in this state for up to 12 hours and it never resolves and it never comes back.

  4. If I add or move a file/folder, Twonky updates immediately (I have rescan set to -1). However, if I rename a folder, Twonky will show both the old and the new. I can access media from the newly named one; but it is extremely annoying to see the old folder name there. Nothing but uninstalling/reinstalling Twonky removes the old folder–NOTHING. E.g., I have tried clicking “Clear Cache”, “Rescan Content Folders”, “Restart Server”, etc. but they do nothing to fix the error. I have rebooted the PR4100, to no avail. I have also tried tricking Twonky into thinking it is a new folder by renaming its parent folder. This works and only shows the newly named folder(s). But renaming its parent back to the original again shows both the old/new folders. The only fix is to uninstall Twonky and reinstall. This takes forever to rescan and then it will be “stable”, as long as I restart the server at least once a day.

As you can see, this is inadequate. I used the “other” DLNA server app on both my DL4100 and PR4100 without a single incident of any of the 4 issues described above. I would occasionally rebuild the database; but that was only once or twice a YEAR and only after making significant changes to the library (adding/removing/renaming/moving large numbers of files–thousands). So far, after using Twonky for 2 months, I have had to restart 1 or more times a day and uninstall/reinstall 12-20 times. This is unacceptable.

My DL4100 gave up the ghost a month ago, so I am stuck w/ the PR4100 and OS5. The only other option is to switch to Plex; but I do not like the interface and, w/o paying for the premium service, there are limitations. So, again, please do not recommend I use Plex.

Please do NOT instruct me that it is a DLNA client issue. It is not. I don’t have these issues w/ Plex and I never had these issues with the “other” DLNA app. Nothing else in my setup has changed (not the streaming devices, router, wifi, switch, etc.).

Please do, however, instruct me on how to find and install the OS5 version of the “other” DLNA server. If my DL4100 had not died, I could give you a name; but it wasn’t a brand. It was some sort of generic, built-in DLNA app I used for > 5 years on the DL4100. In the alternative, where can I find alternatives to Twonky and Plex? I have not figured out where to look and the “store” doesn’t show any others. Is it possible to install other DLNA servers on the PR4100? E.g., if I wanted to try Emby, Subsonic, Jellyfin, etc., is it even possible to install them? Are there any other DLNA servers compatible w/ the OS5? Or am I stuck with Twonky and Plex?

If there are no alternatives available, please instruct me on how to configure Twonky to avoid the issues described above.

Thank you in advance for any assistance.

1 Like

@Ivan2020 You may find your answer by posting in the correct sub-forum.

Are there no other users experiencing these type of issues? Up to a day or two ago, I had a reply here suggesting I rollback to OS3; it has since been deleted for some reason.

Is there any alternative to rolling back to OS3? I would really rather not do that.

Does anyone even use Twonky? If you do not use Twonky or Plex, what do you use and how did you find/install it?

How/where does one find OS5 compatible applications? Are we limited to the built-in app store? Is there no other place to find them?

Thanks in advance for your response.

Thanks for taking the time out of your most busy day to respond with absolutely NOTHING of use.

1 Like

If you had a grasp of English comprehension, you would have understood from my posts that I was not wanting Twonky. I wanted the OS3 version of the DLNA server. In the alternative, I am looking to fix the issues or find a different DLNA server.

Please refrain from responding any further. It is obvious from your “it is what it is” verbiage that you do not have the requisite IQ to help anyone.

Hi, I just would like to confirm the initial post of this thread about a real disappointment concerning the twonky media server. Clearly, the previous one (natively included in OS3) was absolutely simple and efficient in use. I could access to the folder with different connected devices, could listen music quickly and the folder pictures were displayed on all the devices and in a rather nice manner.

With twonky, it took so long to see the libraries in the different devices that I thought that it is not working at all. actually, I understood that I was waiting for something as quick as with OS3 …but it’s because I stopped searching for a solution more than 2 days that I finally saw the music folder pictures on at least one of the devices…still nothing on the 2 others.

Also after the upgrade to OS5, even if I could see the folder on 2 out of 3 connected devices, I could not access to the folder in the windows files manager…thus was no more able to include anything new. Actually I could get around by coming back to the first configuration after the upgrade, created a new folder, moved all the music from the un-accessible folder to the new one. restarted the allocation to the different users and restarted twonky. After that I can now access the new folder with all device and within the windows file manager. One of the 3 devices displays the music folder “images”…the 2 others display the folder but without the “images”. At least, I can get to the music.

This is where I am now. In the mean time I checked if free media servers are available on the internet. There are a few but I don’t know if it is suitable trying installing such a server specially if you have no idea about OS5. The éuniversal media server" available on sourceforge.net sounded interesting…I was even wondering if it was not the one natively in OS3.

Presently I have no other ways than waiting for next release of OS5 and hoping some good changes are included. Hope my English is understandable…it’s not my native language. Have a nice evening.

1 Like

@Ivan2020 Twonky DLNA Media Server 7.2.9 was included in My Cloud OS 3 firmware similar to iTunes and other apps tied to firmware release. My Cloud OS 5 moves all embedded apps outside of the firmware such as iTunes Server, Remote Backups, USB Backups, etc.

The Twonky DLNA Media Server supported in My Cloud OS 5 is version 8.5.1-2.

@julienb: Thanks for a helpful response.

I believe I am in a wait-and-see mode myself. I did not know the native DLNA server brand in the OS3, so I couldn’t search for it. I never remember seeing a brand. Like you, I found it uber-easy to use and it was fast to update. I never saw a config page button, as w/ Twonky in OS5, and the VERY few issues I had were fixed by clicking a rebuild database in the console. If that was Twonky, they sure have introduced a TON of issues. Seems like no one tested on OS5.

If I find a workaround for the music issue, I can live with the video issue, for now. I have not seen the issue you had w/ disappearing folders or inaccessibility on certain devices. All of my content is there and accessible on laptop, Roku, and Amazon Firestick, as long as I reboot frequently. Uninstalling/Re-installing fixes every issue except the 2 song limit issue.

Thanks again.

1 Like

@SBrown: Thanks for a helpful response.

Do you know the brand of the generic, non-branded, embedded DLNA server in OS3 to which julienb and myself are referring? I don’t believe it was Twonky. I seem to remember it just being labeled “DLNA Server”. If it was, in fact, Twonky, then they sure didn’t test their software on OS5. Between julienb and my issues, it is obvious there is something amiss w/ the current version (yes, I am using version 8.5.1-2).

If I could find that DLNA Server, I prefer it to Twonky/Plex; although I am not sure if it is compatible w/ OS5.

Also, if you know, what is required to install an app manually? I.e., if I wanted to test some free DLNA Servers, where and for what am I looking, with respect to the software? Just a Linux distro? I haven’t looked at the NAS OS at all, my Linux experience is dated, and I can find nothing in the manual, forums, or Net using search words “PR4100 install app manually”, or the like. I thought there would be an app store like Microsoft has for various OS5-compatible apps; but it is elusive, if it even exists.

I haven’t had a ton of time to trial-and-error stuff; and I don’t want to brick this NAS. It is < 2 months old and, since my DL4100 died, I don’t have a backup.

Thanks again for your help.

1 Like

Correct. that’s Twonky 7.2.9 included with OS 3 firmware.

1 Like

could OS% not include it in exactly the same way? would make life so much simpler for a lot of users

I’m in the same trouble with my MyCloud Mirror Gen 2 3+3 Tb. Since when I upgraded to OS5 I cant’ use Twonky because I’ve to restatr it anytime I wanto to use a music file on my net. More, in the last week I cant’ access Twonky configuration page because I receive a message thst says: " page not found". I tried to reinstall Twonky many times but the result is always the same. i tried to install plex but with it WD Nas becomes a turtle, always running and media receivers thet return the message: Instable connection". i’ve tried to reconfigure Twonky for 2 weeks but now I’m very tired of this situation. For the reasons I bought WD Nas, now is unusable. Is it possible to downgrade to Os3?

Apparently, it is. Originally, there was a reply to this topic that had a link to the procedure; but it was deleted for an unknown reason and the admin has yet to reply to my query about it. If you search the forum, you will probably find the link. I believe, but not 100% sure, that it was [GUIDE] Revert My Cloud OS5 Back to OS3. However, it states that the procedure only applies to PR4100 and PR2100.

I have found (for me) that not making a lot of changes, which I frequently do, makes the server [reasonably] stable and eliminates the need for me to restart as often. Yeah, I know what you’re thinking, “What good is a NAS w/o changing its content?” But I have found in the last week that if I leave it alone, it does not require restarting. Not a feasible workaround; but there it is. I still have the two song limit on the music, for which there is no workaround.

I am hanging on to hope that a new firmware release will either revert this Twonky version, or fix its plethora of bugs. There have been two firmware releases w/in the past few weeks. Maybe the next will fix my issues. It is obvious to me that very little, if any, testing was done for version 8.5.1-2 on OS5.

It has been either suggested or implied in this thread to rollback my firmware version or revert to the 7.2.9 Twonky. I see only very broad instructions detailing how to do such and nothing that describes the implications of doing so. What I have seen is innumerable warnings about voiding my warranty by doing so. I am not a Linux super-user and I am worried about bricking my device.

I will update this thread if I find a solution to my issues that doesn’t involve returning the device (it is was purchased < 3 months ago for the sole function of acting as a DLNA server and it isn’t working).