PR4100 LCD display is stuck

I recently formatted my PR4100 and the lcd display was frozen, it does nothing, the navigation buttons do not make the screen react either.

the screen looks like this: blue background with white squares.

I checked the settings and all the changes I make to the display don’t seem to have an effect.

is there any other option to solve this? could it be an update? the one I have installed is 5.17.107

Note: the NAS works fine, I can load, review and view the files of all devices, the disks have no problems (according to the diagnosis) and the only problem is the LCD display

dswv42 thanks for the reply.
Yes, I have already tried restarting it and turning it off for a few minutes.
the screen does not change, it is still stuck

I launched the commands but still nothing, I tried with more and less characters and the only thing I got was to change the opacity of the boxes.

this is how it looks

pr4100

I will try and tell you, thank you!

Manually re-install the firmware and it stayed the same, there was no change.

Could it be that a hard reset (with the paperclip) can fix it?

I was able to solve the problem:

The problem was that the NAS needed an internal cleaning. Where the LCD Display is connected there is a ventilation grille. Moisture, dirt and dust can get in there.

What I did was:
Open the NAS, removing only the 3 rear screws, disconnected the strap (from LCD Display to Motherboard) and gently cleaned it with isopropyl alcohol, waited a few minutes for it to dry, reconnected everything and that’s it. the screen worked again.

(post deleted by author)