PR2100 not showing in file explorer on some computers

I have installed a PR2100 on my home network to store media and move files between computers. The install wasn’t painless, but it worked, eventually. For some reason after installing the PR2100 on my network the router could see the device right away but it was over an hour before I could connect via the browser on one of my computers to set it up. When I was finally able to get a connection the first thing I did was update the firmware to the latest version. The firmware update resulted in the warning to not turn off the PR2100. After an hour of looking at that screen I called WD tech support who told me to turn it off, then back on. After turning it back on I could no longer connect via the browser so tech support had me do the 40 second reset. After that I was finally able to connect again via the browser and do what I wanted to do.

First thing I did after that was set the device up to use a fixed IP address and set up my router to reserve that IP address for the PR2100 as well. I rebooted the PR2100, the router, and the computer I was connecting from to be sure everything was correct and worked. No problems with this stage of the setup. I then added the users to the PR2100 that would be needed for my setup and a number of public shares for data that I was going to put on the device. Everything worked fine, I could see the device and the public shares on File Explorer, move files to them and from them, etc.

Then I went to set up the other two computers on my network to access the PR2100. That’s where the problems began.

My network consists of a D-Link router supplying internet, wired, and wireless connections on my network. There are three computers currently connected to the network as follows:

Computer 1, the computer used to set up the PR2100, a typical PC running Window 10 Pro connected to the router via ethernet cable. When I open Windows File Explorer I see the PR2100 listed under Network on the left column. When I select Network on the left column the PR2100 shows up on the right column as a storage device and also as a computer. If i select the PR2100 in the left column all of the shares (all shares are public at this point) show up in the right column. I can connect to all the shares, map them as drives, move data to them and from them. No problems.

Computer 2, a typical PC running Windows 10 Pro connected to the router via ethernet cable. When opening Windows File Explorer on this computer the PR2100 does not show up indexed under the Network in the left column. When Network is selected in the left column the PR2100 shows up in the right column as a storage device but does not show up as a computer. I can double click on the PR2100 to bring up the web login for the dashboard of the PR2100, login, make changes, etc., but there is no way to connect to the shares because they don’t show up. If I type in the network address of the PR2100, \pr2100\nameofshare, or \ipaddress\name of share, in the address bar of File Explorer I can connect to the PR2100 and then map drives, move data, etc., but the PR2100 still does not show up as a computer under the Network selection on File Explorer. After mapping a drive from the PR2100 the device will show up in the left column of File Explorer indexed under Network. If I select the PR2100 in the left column then all of the shares show up in the right column, not just the one share I’ve mapped. In short, I’ve got it working but it’s kind of clunky. I should be able to use File Explorer to navigate to it just like I can on Computer 1.

Computer 3 is identical hardware to Computer 2 but running Windows 10 Home and connected to the router via wireless. Its results in connecting to the PR2100 are identical to Computer 2.

I’ve read hundreds of posts relating to the PR2100 not show up properly in File Explorer. I’ve checked NETBIOS settings and dozens of others but can’t figure out why everything works as it should with Computer 1 but not Computer 2 or 3.

If anyone can offer any suggestions I’d be glad to hear them at this point.

Hi mgarr682,

You should have a look at the link given below.

If the issue still persist then you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.

My Windows 10 Pro computer had the same issue. It could not find my PR4100 or my DL4100.

On both units, I have:

  • enabled LLTD

  • not enabled “Local Master Browser” on either one (it doesn’t work, trust me).

  • selected SMB 3.

I do have SMB 1.0 / CIFS enabled in Windows services on my computer.

I re-booted my computer and it discovered both devices.