Power controller died on 2TB Drive; Can't mount filesystem in new case

I had a 2TB Western digital drive that stopped working. I’m pretty sure it was some issue with the power controller (sparks would fly when I plugged it in, always a bad sign!). I yanked the drive out of its enclosure and moved it to a new case, thinking it would be easy to mount, rescue my files, and move on.

However, I wasn’t able to mount the filesystem. It was originally formatted with HFS+ for Mac OS X. I tried using the TestDisk utility to recover the lost partition table, but it only found one small-ish partition near the end of the drive. I rewrote the partition map, and it turned out to be the Western Digital SmartWare partition – that now mounts and works fine. However, I still don’t have access to any of my data!

I’ve long since ditched the original case, and it’s looking like the USB interface board is crucial. Is there any hope at recovering my files without that board? I hadn’t used any of the encryption utilities, etc., which I would hope means they are recoverable still…

Thanks in advance!

If it’s a drive that came with Smartware tthe the data is hardware encrypted by the board. Data recovery is probably not possible now.


Is it possible to canabalize another drive? I believe it was a 2TB MyBook Studio drive. I’ve got a few 500GB external drives sitting around that I could potentially sacrifice if their hardware does the same encryption…

It’s a gamble because they frequently change the boards. I think you’d also want the same model. Send fzabkar a PM with a link to this thread he is the most knowledgeable on these boards.  Maybe he can help you.


I have no hands-on experience with WD’s external hard drives, so everything I know, or think that I know, comes to me as feedback from end users or data recovery professionals. That said, some data recovery professionals have confirmed that certain external hard drives can be recovered by swapping the USB-SATA bridge board with an identical product of the same capacity. Others say that they have had to transfer the serial flash memory IC from the bridge board to the donor. This flash IC contains the program code for the Initio INIC-1607E bridge chip. It also stores the Vendor ID and Product ID for the WD device.

If your Initio bridge IC has an “E” suffix, then it incorporates 128-bit AES hardware encryption. This means that your data will be encrypted, whether or not you have set a password. A “P” suffix (INIC-1607P) denotes that the bridge does not have encryption. If you connect an encrypted drive directly to a SATA port on your motherboard, then your data will appear as jibberish, as you have already found out. You can confirm that the data are encrypted by using a disc editor to view sectors 0 and 1. Sector 1 will typically contain a repeating pattern of 16 bytes. These correspond to encrypted zeros.

The layout of the drive consists of a user area at the beginning. This is followed by approximately 600MB of unencrypted SmartWare software in the form of a virtual CD (VCD). This VCD uses a hybrid format (CDEveryWhere) that is mountable by Windows, Linux, and Mac OS. At the end of the drive is information required by the Initio bridge for its own use. The external drive is actually a multifunction device. When connected to a USB port, it first enumerates as an external optical drive (VCD), then as a USB mass storage device.

If the drive is installed behind the bridge, then only the user area is visible to the OS. The bridge hides the rest. If you compare the total number of LBAs reported by your software, it will be less than the total number printed on the drive’s label.

Here is a thread where a user has reverse engineered a HP SimpleSave external HDD:

The SimpleSave drive appears to be an OEM version of WD’s SmartWare. In fact the VCD code contains the name of a WD employee (Kathleen M.) who may be able to shine some light on how it all works. :wink:

To address your data recovery problem, ISTM that you will need to be lucky with your replacement bridge board. Morever, even if it is a perfect match, you will need to use TestDisk once more to restore the original partition table. However, before you do this, you will need to confirm that the user area of the disc is being correctly decrypted by the new board. To this end you could examine sector 63. This will be the boot sector of the first partition and should contain recognisable text strings, such as “NTFS” or “FAT32”.

Here are two free disc editors:

HxD - Freeware Hex Editor and Disk Editor:

DMDE (DM Disk Editor and Data Recovery Software):


Thanks for the detailed reply… my data is probably hosed, but at least I can just move on!


I have the same problem. However, I’m not as an advance user, then I would like to ask you some questions:

-You said: If your Initio bridge IC has an “E” suffix. Where is exactly this letter?

-I saw that is possible to use testdisk to repair  the partition. Then, how I have to do it? what type of partition I need to select? 

My drive is a WD MYBOOK II 2TB Mac, which I formated as extended journaled

Thanks a lot!

Pepoman, you need to open the enclosure and identify the largest chip on the USB-SATA bridge board.


There is a big one that says: Oxford Technologies OXUFS936DSE-FBAG F1020 N286ZA N286Z. It’s that the one? if so, what I have to do next? thanks

According to the following documents, your chip incorporates data encryption. I have not seen any in-depth discussion regarding this chip, but I suspect that you may need the original board to gain access to your data. To determine whether your data are encrypted, I would examine the first few sectors of the drive with a disc editor. If you see a repeating pattern of 16 bytes, then these will be encrypted zeros.

OXUFS936DSE FireWire400/800 / USB2.0 / eSATA to SATA Dual Controller:

“The OXUFS936DSE is a Universal Interface (eSATA, FireWire800, FireWire400, USB2.0) to dual SATA storage controller with integrated hardware RAID engine and integrated encryption engine.”

OXUFS936DSE Product Brief:

Parts List (E = encryption):

OXUFS936DS-FBAG … Universal Interface to Dual SATA RAID Controller
OXUFS936DSE-FBAG … Universal Interface to Dual SATA Encryption Controller


Thanks again for the reply. So, exactly what do you advice? how I can recover my data? Thanks!

Pepoman, what exactly is the problem with your drive?


This is the Situation:

-When I connect the drive to the Mac I can see it in diskutility as “not mounted”.-If I manually try to mount it, it will time-out and not mount.

-if I try to run “verify disk” it will fail to verify and say that the disk needs to be repaired-

if I try to repair it, it will start the process and then give me an error saying that the drive can not be repair and that I should backup all my data and reformat the drive

-I can’t back-up any data as I can’t mount the disk. So, I’m stuck.

I have tried:

-I took out each of the drives and connected them to an external SATA enclosure (one at a time). However, the enclosure was unable to be recognized by the mac. Not sure if it was an enclosure or hard drive problem

-I have emailed several times WD, but they are not providing any solution, in there last email they said:“You can dismantle the enclosure, take one drive at a time and plug them directly to the computer through SATA. In this case, you might be able to access your drive’s content that way. They should show up normally as HFS. For more information, please refer to the article provided below.”

-The issue as you pointed correctly is that the drives can’t work independently, they need each other to run.

Others in the forum has adviced to buy the same WD external drive and then connect my two drives into them and see if it re-builds. Not sure if that will work. My view is that there is an issue with the partition, which needs to be repaired. I know there are some programs outthere that can do this, but not sure which one or how to do it.

I’m not an advance or expert user as you are, so I’m quite limited in terms of getting into coding or using the console of the Mac.

Please advice / help me as I desperately need to recover my data. Thanks a lot!