Possible to use "My Book USB 3.0 Essential 2TB" with another external casing?

My MyBook Essential USB 3.0 2TB external died 2 days back. It was 5 months old. Above all I am worried about my data. My question is - Can I take the drive apart and use it with any other casing available in the market? What is the deal with the USB micro B port? Is the drive inside of the casing a normal one?

I don’t care about the drive anymore and I dont want to pay thousands of dollars to so called data recovery centers. I have checked the adpater and cable and both are working fine, which leaves me with the only answer that the drive has failed.

Can anyone please explain about the complicacies involved in doing so and what all things are needed to be taken care of? Any help in this matter will be highly appreciated.

Two problems opening the drive voids the warranty. Any drive that comes with Smartware used hardware encryption. Even if you get drive connected and recognized by PC data will be encrypted and useless. This is done by the circuit board with the USB ports.


Thanks for the prompt reply. The hardware encryption which you are talking about is present in the all the drives that comes with smartware or just the drives that have smartware installed on-chip?

Does this mean I am stuck with a dead drive with no way to get my data out?

I believe with all of the drives that come with Smartware are like that. What do you mean when you say the drive died? Did you try moving power adapter straight into wall outlet? If the power adapter is bad WD willl probably send you a new one.


The power adpater works (I checked this by using this power adpater to power on another external HDD, and it worked fine) and so does the data cable. By the drive being dead, I mean the system is not able to recognize it anymore. Not just explorer, the disk management utility as well as device manager, the device won’t show up anywhere.

After powering on the drive, it spins only when I press the soft-switch, but the system doesn’t show any signs of the drive being detected. Also the drive exihibts same behaviour whether the data cable is connected or disconnected, i.e. the LED would flash for about 5 seconds and then stays on.

I assume you are using a USB 3 port on the PC. Have you tried it in a USB 2.0 port???


No, I am using this HDD on a USB 2.0 port. The problem being all the WD MyBook essentials are hardware encrypting the data by default, so my only option is to somehow get the drive working. fzabkar helped me narrow down the issue to a faulty usb connection on the PCB of the drive. If that is the case I should be able to get it fixed and extract the data and then I am planning to dump the external case. Its a shame really, cause the drive is just 4 months old, but I really don’t have any other option.

I never bothered to check that this version of WD is hardware encrypting the data, which was my biggest mistake.

Thank you guys for helping me out.

P.S. - Moderator please close this thread.