Portable WD My passport for Mac not requesting password

I have a new WD My Passport portable for Mac. Everything was working fine, and one day suddenly… hell… Several issues are occurring:

  1. When I plug in the USB port into the Mac, it does not request password anymore. I am using the cable that came with it.
  2. Sometimes the tab on the upper bar gives me the option to back up, but when I try, an error message shows saying that “the back up disc is not connected”. I have two UBS ports on Mac. I tried both and it does not work.
  3. If I try to eject “my passport for Mac” and click on it, nothing happens. When I unplug the cabe I get a message saying "Eject “my passport for mac” before disconnecting or turning it off… which I did!
  4. When I go to Finder > my passport for Mac, I can’t find the Files I transferred to the backup disk which are super important. It seems I can’t get into the WD my passport because it does give me the option to enter my password. I went only and tried several options, but could not resolve the issue.
  5. Now in the upper bar it’s showing the message “Time machine not configure”. This is new message that was not showing before.
    Can you guys please help me out with this. This is really upsetting, This is the second portable WD I bought, and the first one had similar issues.
    Thanks. Andrea

Hi AndreaF,

We have sent you a message. Please check your Community Message Inbox.