Port-forwarding on My Cloud Home Duo 8TB

Hi to everyone. Since I’ve bought my MCH Duo 8TB a month ago, I have always had relay connection type set, with incredibly low data transfer speed especially out of home.

The MCH is directly connected to the router, and I have a static ip adress (so I can reasonably exclude a double nat environment as confirmed on whatismyip.com).
From my router’s menu (Askey RTV1907VW) I’ve set a fixed ip adress for the MCH in the DCHP section, and enabled UPnP from which I can see that the MCH has opened ports 443 (int) and 49592 (ext). Moreover, i checked on canyouseeme.org that these ports were actually open and running and the site confirmed.

Nevertheless, I still cannot establish a port-foward mode on the MCH from any device connected (laptop or smartphone), from my home network or outside home. I’ve already contacted WD customer service but they weren’t able to solve. Do anyone have any tips to help me please?

@Aim185 can you private message me your support case number?