Plex secure connection issues - assistance requested

After I have enabled and then configured Plex from the MY Cloud Home device, I am unable to use Plex due to the below error message:

Unable to connect to “MY Cloud Home Due” securely
Its “Secure connections” setting may be set to disabled, or you may need to adjust some settings on your network… etc

I am not a network expert and I am getting confused with regards to whether I need to enable port forwarding on my router, etc. I am just not sure that if this is what I need to do then what settings I should be making, etc.

any advice or request for additional info would be very much appreciated. Thanks.

Hello Rich69,

There can be many reasons behind such issue. You should try disabling the Web Protection from the Anti-Virus installed on your computer, change in the router’s firewall settings or enabling the port forwarding on the router for Plex using port number 32400 or 32469.