PLEX on PR2100 unreachable even after uninstall/reinstall


#1

HI - is there “clean up” tool for the PR2100 App uninstall process? My network config changed (e.g., external IP address from ISP), and now all my clients think that PLEX on PR2100 is unreachable. Even after I uninstalled and reinstalled PLEX on the PR2100.

I know the uninstall was not thorough since after the uninstall/reinstall, it came back up with all my libraries intact, playlists, everything. And the bad IP address.

So in detail:

  • At one point the PLEX server had two IP addresses associated with it: the Local/LAN one in the 192.168.* range, and an external one used to connect to the outside world (e.g., PLEX servers). That external address changed and the one associated with the PLEX server is no longer valid. I can’t seem to break that relationship.
  • It has not helped for me to turn off remote access. Turn it back on again. Whatever. The Clients all seem to see the old external IP address and therefore cannot connect to PLEX on PR2100 since that external IP address is no longer valid
  • PLEX server is fine, from the point of view of the web client from the PC.
  • Actuall DLNA service from WD PR2100 and PLEX runs fine when I enable it. I have now disabled it.
  • PLEX client on Vizio TV and PS4 can both see the server, but think it is unreachable.
  • Renamed the PLEX Media Server “friendly name”, and Clients tracks that name change, but still unreachable
  • Force changed the IP Address of the server - no benefit (the clients followed it but can’t connect)
  • I logged in using SSHD, and poked around, but nothing obvious.

Is there a config file I need to flush out? A permission problem?
Thanks
Dean


#2

The problem is usually caching in the Plex client. Cold reboot your TV (plug the power for several seconds).

Make sure you’ve got the latest version of the Plex media server installed.
You might want to set a fixed public port in the Remote Access tab of the server.

If you still have issues, have a look at the plex logs in /shares/Volume_1/Nas_Prog/plex_config/Plex Media Server/Logs.


#3

Thanks - these were really good suggestions, but unfortunately they did not work.

Cold reboot of TV (unplug, wait 10 minutes): still same problem, which shows:
“HomeMedia2100 is offline or unreachable”
“We tried to connect to 192.168.1.64, 172.17.42.1”

That last IP address is no longer valid. It was valid once, but no longer.

Plex Media Server version: yes, up to date

Set Fixed Public Port in Remote access tab: that is already set to 32400 by default. Not sure what you mean to change it. I can change it, but to what. I thought I could change the fixed external IP address, but I see no such option

Looking at the logs was not much help. I searched for “ERR”, “WARN”, UNREACH" etc. Nothing obvious

Still not able to connect. Hoping someone can help
Thanks
Dean


#4

This is the order in which to test Plex availability:

  • From the wd dashboard, press configure, which leads to http://NASIP:32400
    This probably works fine.
  • From within your home network, go to https://plex.tv, log in and launch.
    This also works fine I guess.
  • From outside your home network, e.g. use the browser on your phone (in desktop mode) on data connection, go to https://plex.tv, log in and launch.
    If this works, it means the server is connected properly to the public internet.
    Minor note here: some devices don’t support https for plex. Consider to keep secure connections optional.
  • From any other device outside your home network, try to log out to enforce a cache flush. Maybe delete app data/cache or so.

#5
  • From WD Dashboard (access from Chrome browser on PC on same LAN as PMS): check, all good

  • From within home network (from phone on WiFi LAN using Chrome): check, all good

  • Extra check: All good from Another Vizio TV on home WiFi! I just remembered I have another Vizio Smart TV and when put on network and Plex installed, it access the server just fine. So Problem is not with Server. It must be with the main living room Vizio TV. (It was the victim of networking changes during Plex Setup)

  • From Outside Network: I have not checked, because this is not a goal of mine. Are you suggesting that I should do so to get the main problem TV to connect via external rather than internal network? I guess I could try that. I have not yet done that.

I tried a few other schemes to get the main Vizio problem TV to forget that the PMS is not “192.168.1.64,172.17.42.1”. It is that memory that seems to be messing it up.

Maybe I need to go to Visio and figure out how they really flush the TV cache.

thanks again for your help