Plex Media Player no longer supported

Since Plex Media Player support is terminated, will this have any impact on Plex application that is available on MyCloudEx2Ultra?

I was planning to use Plex Media Player to manage my library, create playlists etc. What do I do now?

Although its not supported by WD, Plex are supporting and producing a version for the WD EX2 Ultra, you will need to download the specific EX2 Ultra version from Plex and install it manually.

I am using Plex media server with no issues on mine, just ensure the clients are using Direct Play so it is not transcoding, as the EX2 Ultra doesnt really have the horsepower to do that.

First of all, thanks.

  1. I was using the Plex app that comes with the WD NAS but I abandoned it due to continuing, unfixable problems with metadata mis-matching. Is this the version of Plex that you are suggesting?

  2. What is Direct Play?

I binned the version that came with it and got the updated version direct from Plex. It is maintained and updated regularly and you will get notification via the NAS or Plex App if the server needs updating, very easy.

Select Wester Digital as the Platform then choose the correct package using the Yellow package button.

I have had several updates in the few months I have been using it.

I think, by default, that client apps accessing the server should be set to direct play (its one of the client side app settings), so shouldnt be an issue. Just something worth being aware of if you experience problems.

So direct play is an option. I thought you were talking about a client app like PMP.

Which client will WD “talk to”?

Specifically, what are YOU using to build your library, playlists etc?

I have been carefully building my source music file library on my WD NAS using Flac. Waiting to find a way to stream it to my Bose speaker. Oddly enough, the most dependable client I have used so far is (don’t laugh) Windows Media Player. I need to get the WD NAS to start streaming so I can turn off WMP on my client.

You have presented me with the most progress I have had in over a month.

Ahh, might be going a bit out of my field based on that reply!

I am using Plex Media Server on the NAS and accessing it via the Plex app on SmartTV, Firestick, PC etc.

The ‘library’ is just a folder on the NAS (Film, TV, Music etc) then I just create a Music Library in Plex and point it at the folder. The app then does everything for me but obviously need to access that media via the app itself. Main use for me is video files on my TV etc.

I have never looked at using it for streaming directly to audio devices, so probably can’t help there I am afraid!

What is the client device running WMP to access the audio files?

In summary your environment is:

EX2 Ultra version Plex server on WD NAS with
Standard Plex client app. I would put the client on a
Windows 10 PC.

I now run Windows Media Player client on a Windows 10 PC. My speaker is a Bose Soundtouch IV.

It will be good to get the NAS up and running with an embedded media server. The Bose unit will find the media player on the NAS. I already know that. So I am good that way.

I am not sure that I know how to manually install the
Plex Server onto the WD NAS. Is it similar to manually installing an update?

I will try to get this set up this week. :ok_hand:

I was able to manually install the Plex server that I downloaded. Building my music library now.

I can’t tell you how much I appreciate your help. In less than 24 hours, you solved problems that have been bothering me for 3 weeks.

My problems all centered around the Plex server that comes out-of-the-box and the Plex Media Client.

Manually installing this new app has resolved everyone of my issues. I searched the KB for days chasing my tail on the configuration.

Why is this a secret?

Glad it seems to be sorted out, hopefully will all work as expected once the library is built.

I had some issues with the version that came with the box. After researching I was surprised it was still included as WD dont actually support it any more.

I have had quite a few updates to the version in the last few months so it looks like it is being actively maintained and updated by Plex. You will get notified when a new version is available (via the Plex app), just need to manually download and install it each time.

The NAS will tell you you already have it installed and ask if you want to reinstall the new version, just click yes and it will do it all. Installing the new version will not impact any existing libraries.

Once I finally figured out how to manually install the Plex server I was ok. It failed on the install several times before it worked. So inconsistent.

My current concern is that music Genres in my metadata has been completely ignored, despite using embedded tags and Preferred Local Media. It is the inconsistency that drives me crazy.

I have been using Genres to stream the type of music that I want to listen to, on any given day. Initially It seemed like a good idea.

Should I build a bunch of Playlists instead?

What version of Server are you using, it should be v1.19.2.2731.

I have approximately 95Gb of Music (all MP3s) on my NAS but I don’t really use it for streaming music files (just as a store), so am not too familiar with that side of things. Mine are in a single Music folder and then subdivided by artist, then again by Album etc. I honestly don’t know how good the metadata is on those files as I have never looked, but Plex is a little inconsistent on mine. I just assumed that was down to the files themselves and as I am not streaming music from it I have never bothered to look in more detail.

I have seen, on occasion, that when I add a file to a library I do use, it does not always identify it and update straight away from the Metadata. When that has occured for me I have manually forced a refresh of metadata for that file and it has always picked up the right info second time round.

So, I would give the following a try and see if that helps first of all…

  1. Refresh the metadata for the entire library. This is done from the left side menu in Plex, next to the Music library click the 3 dots icon, select Manage Library > Refresh All Metadata. This can take a bit of time to complete. I am doing this on mine now to see what it comes up with, it does appear to be working as I can see the unmatched items updating with album covers etc.

  2. Manually refresh the metadata on individual albums that are not correctly identified. To do that go into your Music library, then in the right (main) pane click the 3 dots (bottom right corner) on the item that is wrong. Select Refresh Metadata and let it do its thing.

  3. Via that same menu look at the Fix Match… option. This will list all the potential matches Plex has come up with, it may have identified against the wrong one and can be corrected here.

With films you can set them into groups, this is done by clicking the Edit option (bottom left corner of the individual item), selecting Tags from the window that opens and updating the Collection field. This may already get part of your metadata tags? If you have created collections then you will have an additional option at the top of the right (main) pane called ‘Collections’, this is in additional to the default ‘Recommended’ and ‘Library’.

See how you get on with that, hopefully will fix a good number of them for you. It might also help to ask for more info on the Plex specific forums as they are likely to have more indepth knowledge on the software.

The update just came out to me today. That is working and gives me hope that we are all making progress.

The detailed description you provided will be very helpful to everyone.

My biggest issue is with Genres. The Genres that I methodically set up, when I ripped CD’s and modified my metadata on mp3tag, are all being ignored. This, despite the fact that I had the library set up to use embedded tags and Prefer Local Media.

I will do the refresh etc and report back.

I deleted my library, cleaned everything up, bundles, trash and the database.

I also did the Plex Dance just in case.

Added a new library, scanned and refreshed metadata. I have a music library that I can live with.

Genres still aren’t correct. The Genres that I created in my music files, with mp3tag utility and dBPowerAmp, are being ignored.

Thanks for all your help.

Hi, I have been doing some work on my Music library and noticed a setting that may be of benefit to you.

If you go into Plex settings, go to Libaries and Edit your Music Library > on the windows that opens go to the Advanced option and look for the following setting, its the 5th line down in the Advanced settings:

Prefer Local Metadata - This setting was disabled for me when I created a new library, meaning Plex will prefer any externally sourced metadata over anything you have set, if it finds both. If you have made various settings in metadata I would suggest enabling this option and see if that helps.

Thanks for reaching out. I am aware of this setting and have been using it. I was wondering, however, if it actually takes local data, because I have been getting confusing results with it.

The confusion got worse, as I went back and forth between a clean library and a library full
of unknowns. I think what has been happening is that have been getting a clean library…then
if I “refresh all metadata” with “prefer local metadata” I have been re-introducing Unknowns from my metadata.

So… I have just found a bunch of albums where Track 1 had no metadata other than Unknown…every column…but only
Track 1. How the heck did that happen???

Now I am tracking down all the bad metadata. Fortunately my collection is not that big. Hopefully that will resolve my issues.

The good news is that the last update has some good features for sorting albums by Genre, mood, style etc.

Get
Outlook for iOS