Plex install not working on a brand new 4T


I have a 2T MyCloud home which works perfectly in every aspect - its about 6 months old.

I recently bought a 4T and it’s not allowing me to install Plex. The folder is not created and you cannot log into Plex app and make adjustments to the server. This is really surprising as clearly the setup will work, I just can’t get into the server settings for the 4T.

Ive done a bit of reading around - I switched off the 2T just in case that was causing issues, Ive tried many times to shut down Plex and restart it. Ive deleted old versions of the server in the app. Ive tried going in cognito mode. Nothing makes a difference.

As soon as you click on the configure button, you just go through to the app homepage, not configure flex. You can see the server listed under more and it’s listed as unsecured, so you can’t make any adjustments.In every other way the server acts as it should, you can log into the WD home app no problem and use it as a drive - but to me the raison dete is Plex. It’s just a box wasting money without that.

Checking the service version as I can in the Plex section - both servers have the same number. It’s just a mystery as to why the older one works and a new one doesn’t.

Can anyone shed some light on this?