Plex for My Cloud EX2100 Configuration Broken

Plex Version
My Cloud OS 2.10.310

Every time I click on the configuration page from the Apps widget it opens a new browser tab. In this browser tab all it says is page cannot be displayed. It worked for a few minutes after i updated to the current version but nothing since.

Plex doesn’t show up on anything: iOS app / Rasplex / browser based.

I upgraded the plex on the WD NAS by clicking manual install and using the file from the plex downloads website.

Any ideas on why plex isn’t working for me?

You might want to try performing a “System Only” restore, try turning off and then on the Plex app. You might also be running an unsupported version, it could be a good idea to try and remove it, then add it automatically from the bundled app list.

I deleted the updated version (downloaded from for the EX2100. I re-installed the plex app from the default app list. I then turned it on and everything works. After a while of using the app the “configure page” stops working and is no longer accessible. Also the plex page with your media displayed on it says the plex server is no longer reachable. Would doing a system restore erase my media on the server? I just bought the device and everything is finally centralized on the device. I just started toying with plex and trying to get it to work but it seems the software is wonky and works intermittently.

Currently my only work around for the configuration page not working is to turn the plex app off then back on. This is annoying!

My wife doesn’t no how to work any of my network equipment. So, when I am at work she can’t fix it. She just wants my RPI2 to play movies via rasplex.

Is there anyway to create a cron job that will restart the service if it stops or has a failure of some sort? I have limited experience with setting that up from using Open Media Vault for my RaspberryPi2 before I got my WD EX2100.

Guess what, I am now experiencing the same problem with you :sweat_smile: . I’ve tried some stuff and opened a case with WD to prevent time loss. I’ll update this post as I receive updates from WD.

And for the things I’ve tried; the “System Only” restore does not touch the data on the drives (movies etc.), but not sure if it removes Plex’s cache (thumbnails, metadata about content it streams etc.). I believe it would… After a “System Only” restore, you might have to re-add the Plex app and wait for it to re-scan for metadata generation.

Yeah, the device is really nice. If only we could also solve this Plex issue! Everything else seems good.

And seems like you could actually setup a cron job to do that, look what I found;

root@WDMyCloudEX2100 plexmediaserver # ls -l
-rwxrwxr-x    1 1008     1008           508 Aug 23 14:12 apkg.rc
-rw-rw-r--    1 1008     1008            40 Aug 23 14:12 apkg.sign
-rw-rw-r--    1 1008     1008          1169 Oct 28 12:35 apkg.xml
drwxrwxr-x    3 1008     1008          4096 Oct 28 12:35 binaries
-rwxrwxr-x    1 1008     1008            17 Aug 23 14:12
-rw-rw-r--    1 1008     1008            73 Aug 23 14:12 index.php
-rwxrwxr-x    1 1008     1008           305 Aug 23 14:12
-rwxrwxr-x    1 1008     1008           332 Aug 23 14:12
-rw-rw-r--    1 1008     1008         26207 Aug 23 14:12 plexmediaserver.png
-rwxrwxr-x    1 1008     1008          1048 Aug 23 14:12
-rwxrwxr-x    1 1008     1008           897 Aug 23 14:12
-rwxrwxr-x    1 1008     1008           523 Aug 23 14:12
-rwxrwxr-x    1 1008     1008           762 Aug 23 14:12
drwxr-xr-x    2 root     root          4096 Oct 28 12:36 tmp_transcoding
root@WDMyCloudEX2100 plexmediaserver # pwd
root@WDMyCloudEX2100 plexmediaserver #

I assume that the dashboard is simply calling and when you turn it on and off.

I also have one last suggestion, I had to switch to native DLNA (“Settings > Media > Media Streaming > On”) because of the issues with Plex. I am now watching content from my iOS devices with the app below. It’s really nice (4.5 stars with 3005 ratings), I don’t really look for Plex that much ;

You also should turn on “Media Serving” for every share that you want to stream, after turning on “Media Streaming”.