Plex Configure sevice gateway timing out

My Plex service on a WD Mycloudhome 4Tb was working fine for months and after a reboot does not seem to see the server now
Was going to try and reconfigure the server to fix but the WD portal button to run the Plex config just gets a “Gateway Timeout” and I cannot Plex to see the server anymore.

Try this

  • go to services
  • disable Plex
  • Wait a few minutes
  • enable Plex

Appreciate the response but its its the Services I cannot reach, it constantly goes to “Gateway Timeout”
I never reach the part where I can disable / enable.

My WD Discovery shows that the Plex App version was updated on Monday, March 12th 2018 and thats when it stopped working,

Do you have any more ideas? Still getting gateway timeout from Plex Service button

Sorry I don’t have a solution for you. I have a similar issue, but mine is not only with Plex. What happens, exactly every 5 minutes the MyCloudHome disconnects from the network for a second or two and connects again. This causes all the services which connected to the unit to lose the connection. I called support, they troubleshooted the problem for days, and then RMA-ed the unit. Guess what, the second unit comes in, I connect it and the same issue. I tried another switch to make sure it’s not from my switch, again the same.

What is the make, model and firmware of your network router?
What is the make, model of any switches between the My Cloud Home and the router?
Who is our ISP?
Is your router configured for DHCP Reservation?
Does it support uPNP?
Any other wired equipment on the network?

I gave up waiting, managed to copy all the Data to another drive, wiped and reset it to factory settings and have now set it all back up again and copied the Data baclk across, its working fine. (at least for now)

Plex were good, they at least made an effort to assist but as they pointed out it was locked out on the My CLouddrive and no Plex pps were able to connect to it.
The support call I logged with WD was a complete joke, they took 5 days to even respond and then just sent me a link to the support page I found myself (and had tried everything) on the first day I had the issue.
I had brought the MyCloud home to replace the MyCloud that had recently failed just outside of warranty
Gotta say I am not loving WD products, software or support.

Oh Well, at least it’s going while I look at a more reliable alternative

Please try this solution to resolve Plex issue

Disable Plex

  • Open a web broswer to
  • Sign In your My Cloud Home account
  • Click Services
  • Click on Plex
  • Click Disable
  • Click Disable Service at the popup
  • Reboot the MCH
  • Configure Plex

Hi there,

I have the exact same issue as Richimundo and when I try to inactivate the PLEX service I am always getting an “unexpected error” and I am being asked to try again later.
I tried this couple of times with no result.

I have a same problem, Does anyone any solution?. Thanks.

1 Like

i had the same issue of PLEX not being able to find MY Cloud Home Server.

I wish to share that this solves the problem. Restart PLEX app on My Cloud Home apps.

This has been a continuous issue. I have to hit the Configure button daily on my home computer in the My Cloud dashboard, otherwise the server is not found on Plex. Its pretty annoying. I travel weekly, and I cannot access my media without having to call home and hoping someone is there to login and reopen Plex.

Has anyone found a fix to this yet?

@Thurm What version of firmware is your MCH? MCH should be 5.0.2-102
What version of Plex? Plex Server should be Version

In the end I gave on WD support advice, very rare to get a reply and they did not appear to listen, just kept telling me the Plex On - Off fix, despite me advising I could not actually reach it as it hung before that happened
I ended up getting another 4tb drive (from a more reliable company S*****e) and then copying everything over with command line, then I factory reset the WD MyCloud home and rebuilt it all again from scratch, works a treat although I still have to reboot the WD device about once a week as my devices dont always see it.
I now shudder everytime I get an email saying your drive has been updated and go home with fingers crossed
Crazily I now also do regular backups from my WD “Backup device” just in case it craps out again.
I am an IT engineer with a lot of experience and would not recomend this product to anyone who isnt technically savvy or patient.

1 Like

It does not fix the issue if you get the “Unexpected error” before you can even reach the Plex switch

1 Like

I went home last night and checked to make sure the WD Firmware was up to date, and it was. I also checked the Plex media server, and it too is the most recent version. There were no updates to do.

I have the same problem and I can’t “Disable Service” because the reponse is “Unexpected error” and when I trying to reconfigure get “Gateway Timeout”. Can anyone help us?

Hello ! I am having the same problem ! Did some one have sucess to solve the plex problem ? thanks

I’m experiencing the same issues, where are the WD product support teams ? Why is there no support for this product which has a media sharing service that I bought into which does not work!