Please help, Wdmycloud (gen1) Solid Red Light didn't change!

My wdmycloud gen1 4TB unit became unreachable (status led is solid red) so I decided to test disk on computer. Badblocks found many bad sectors so I ordered a new HDD (wd red - 2TB NAS hard drive).

Following the guideline by @Fox_exe at:
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXF4aFpYS2dzMEE

I created partitions and copied image and installed it to mycloud, however solid red status didn’t change and it is not reachable.

Would you please guide me what else I can do?
If possible I will appreciate if somebody can share me the 2TB image file for wdmycloud Gen1.

Thanks & regards;

Tolga

http://wd.hides.su/wd/Cloud_gen1/Virgin_img/
https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/ (“disk_image.10g.bin” *gz and *txt)

Typically one as to wait tenminutes or so after the fist gen my cloud reboot. The front led will still be red. Use a web browser and access the my cloud dashboard. Then select Settings > and do a Quick Restore.

1 Like

Thanks for your replies.

@Fox_exe, I have installed the image in you website unfortunately device is still not reachable with solid red status led even after waiting 1 hrs with network cable connected to it.

I think device board is also defected either during my de-installation & installation process or during when hdd is crashed.

Its almost impossible to destroy mainboard and bootloader on it.
Just try other methods or buy USB-UART (1-2$), connect to device and watch what happend inside.

Hi @Fox_exe,
Thanks for your message. Can you please guide me how to connect UART and how to collect data over UART?
Many thanks in advance,

Rx to Tx, Tx to Rx, GND to GND.
Use PuTTY for connect and enable console log (Or just copy all from console)

115200 baud rate, 8bits, 1 bit parity

(this part seems to get overlooked, but is very important for successful connection. Just adding it.)

I have obtained CP2102 (UART - USB) and soldered the UART pins on the wdmycloud board and connected to computer and with PuTTY set to 115200 baud rate and trying all possible configuration options and switching TX&RX cable to CP2102 etc I think I have tried all possible options. Unfortunately I didn’t capture a single character on screen.

Did you connect tx to tx and rx to rx? This would be wrong. You need to connect tx from the my Cloud to rx on the USB. Then connect rx on the my Cloud to tx on the USB.

I have tried both options… I mean at first, I connected TX-TX and RX-RX and then decided to try the other option as well TX-RX and RX-TX which is a better config I believe…

Unfortunately, I was unable to get any response from the board.

When you run putty what option do you use? You need to know which port the USB is connected. You need to use the serial option. You need to set the baud rate correctly.
If the connection is working when you type in putty it should be echo’d by the My Cloud.

PS you need to check device manager to see what com port your usb is connected. Then you need to use that com port and set the proper parameters. My laptop uses com4 with 115200/8/1/none/xon/xoff

I have used exactly the same options: 115200/8/1/none/xon/xoff, and double checked and confirmed the comport number to be correct.

@tozden, Solder wires on the other side of WDMC.
Only fron side is connectred to CPU.

Dear all,

I have removed and re-soldered the UART cables from PCBs backside to front side as @Fox_exe suggested unfortunately wdmycloud mainboard does not give any response on my computer screen. I have tried everything to understand and solve the problem but I think I need accept the fact that this board is dead and I shall let it rest in peace…

Here I would like to thank all of you but especially @Fox_exe for generous support you all have provided to me.

Although failure of this product created catastrophic results for me which also created a huge disappointment against this product and even the vendor, but I am very surprised to get high quality and extensive technical information and support from this community which neutralizes all bad feelings and even creates a sympathy for Western Digital.

I hope Western Digital management will receive this feedback and honor all these generous experts who volunteer to share their expertise with us.