Please, help. WD Elements 1Tb doesn't stop loading and is inaccessible

Hello, I need help. My one-month-old (almost two) WD Elements has been inaccessible in any way possible for the past three weeks. I plug it in and it that little green bar on My Computer doesn’t reach the end (in other words, in doesn’t stop loading). I’ve tried some things I’ve read online, but nothing has worked. I’ve plugged it to other two laptops, I’ve tried using a data recovery program (which worked partially at first) and some other things I don’t even remember.

Can’t create partitions, can’t access its properties, can’t use the Lifeguard-something program.

The sad thing is that I can’t send it back to the shop (yet) because I need to rescue some important files I have there.

Please, someone help.

Hello pbateman412,

I would suggest you to try different USB cable and contact WD support if the issue persist.

Refer the link provided below for contact details.

I’ve tried that with my other WD Elements HDD’s cable. The issue persists.

I’ve found out WD actually has a little support center here in Lima (Peru) and I’m going there one of these days. Thanks, btw.