PLEASE HELP! IP Address Issue AND?/OR Cannot View /Download Files Off My Cloud

Hi all, I apologize in advance as this is my first ever post to a board. I have the old My Cloud EX2 (00 in S/N) and have spent more than 40 hours researching and changing settings in my laptop to view and transfer files out of My Cloud. If I go to the IP address of the device I can see the dashboard, but when logging into, I can’t get past the password stage as it tells me “My Cloud device cannot be found.” I cannot access the drive via the Window apps either. One thing to note: my Linksys Velop runs at: 192.168.1.x BUT the IP address of the My Cloud is:
Through an older laptop today I was able to briefly access the files via I kept reading that the Cloud needs to go to a static IP not a dynamic (though neither look to be selected in the dashboard). In the dashboard its set to Dynamic. I had to do a reset on the Cloud after tying to change the IP address in the network settings. I did not do it right. I tried to set it to static: (outside the dynamic range) but it wouldn’t save and (even though it was in the dynamic range) because it let me save it. I could not access the Cloud at all after that until I did a reset (back of the cloud unit). It reset back to (again my router is at How do I set it to an address within my router?
Now, I can no longer even view the “myfiles” on the old laptop. Ideally, I would love to be able to use my My Cloud again, but I would gladly settle for just getting my data off the darned thing. I did a diagnostic self-test in utilities, and it failed, if that helps.

Thank you in advance,

This appears to be a network issue. Troubleshooting this would be difficult, least of all because we don’t have a clear view of how your routers are setup (mesh, access point, double NAT?) or how your network looks like and where each device, your laptop and NAS connects to.

For instance, you appear to have a Linksys mesh system, which consists of minimum one router and one access point. This is probably why you have two sets of private addresses. Checking online, it says “ is an IP address which routers like Linksys and other network brands use as an access point or gateway.”

If your NAS is getting a 192.168.254.x address automatically, while your main network is on the 192.168.1.x subnet, I suspect you could have a double NAT setup, and your NAS is connected to an access point and not the main router. Meanwhile, if your laptop is connected to the WIFI on the main router, it will not be able to access the NAS on a subnet behind it without port forwards or static routes.

I believe an easy fix would be to attach the NAS to the main router. Then login to the router, it’s address should be, and have a look around for the option to do DHCP reservation. I don’t use Linksys, so I’ve attached this link for you to follow:

A DHCP reservation is the equivalent of setting a permanent or “static” IP address to be given to any device connected to the network. You will need to enter the Ethernet or MAC address of your device and assign it a easily remembered IP address. Linksys routers keep a list of the IP and MAC of every device connected to it, so it’s just a matter of ticking a box and adding it to the list. Now, if you attach your NAS to the main router and assign it for example, you should be able to access it at this fixed address permanently. Do take note that each octet or “piece” of the IP address accepts values from 1 to 254 (the full range is 0 to 255 but the first and last are reserved). Setting it to 260 is out of range, so it will result in an error.

Meanwhile, go back to your NAS, do another reset, and ensure that your IPv4 address is set to DHCP only. Let your router do the address assignment, and don’t do any static IP setup in the NAS dashboard. If you have followed the example above, you will get for your NAS if you did the DHCP reservations correctly on your router. With this done, you should be able to access your NAS from your laptop, whether if it’s connected to the WIFI on the router or access point.

Thank you so much for your assistance and direction. I wanted to provide you with more details on the Wifi/Router/Switches used before implementing your advice. I use an Arris NVG modem (Frontier internet) whereas I’m not 100% sure its set to modem only and no wifi enabled (will work on today) and a Trendnet switch (a box to connect wired ethernet items like the My Cloud) that is connected to a single “node” Velop. The Arris modem is plugged into the Trendnet switch too (could that be my problem?). Thank you again, Thexchange

It looks like you’ve found the source of the problem. Yes, the modem should not be connected to the switch. Most cheap consumer switches are unmanaged or “dumb” switches that do not issue their own IP addresses; they work as an extension of the main device they are connected to via the first port and get their IP addresses from there. Connecting the modem to the switch causes it to be on an IP subnet that is different from that of the main router. Having two subnets is why devices don’t see each other easily. A proper setup would be like this:

Arris modem —> Velop router → Trendnet switch → NAS + rest of wired devices

Leave the Arris as is, in its default setting, the way it came from the ISP. Changing any modes or attempting to setup WIFI there would cause more issues. There should only be one cable from the WAN port on the Arris that goes to the WAN port of the Velop. If your Velop is a two port router, the other port should by default be the LAN port, and another cable then goes from that to the Trendnet switch. If the Velop has more than two ports, it should also be fine to connect the NAS directly to it (everything will be on the same subnet now).

This way, the Arris issues a public IP address to the Velop, while the router then takes care of issuing private IP addresses to the Trendnet switch and the rest of the network. From here, just reset the NAS back to the defaults, and the Velop should see it and assign an address automatically. Or if you prefer the NAS using another permanent address, then carry out DHCP reservation on the Velop and assign one from there.

Good answer.

As stated, It’s always best to have static address from the router. Assigning address on the NAS can cause heartburn if a router change results in addresses on the REST of the network to move to a different subnet.