Please help , cant connect my ( my cloud ) Local or over the internet

i have ( my cloud ) for 3 years now and i never could setup it as over internet connection i was always use it as local internet

now i cant do any thing

using Windows 10
Can access the website of the local my cloud set up page
in Cloud Access i got ready
But the window cant see it as ( network map )
or even over the internet
it even send me mail when it get start Screenshot (30) Screenshot (31)
Please check the Pic and help me guys

What specific My Cloud model do you have? A single bay version or a multiple bay version? If single bay, what version (first or second generation) is it? What firmware is it running?

It appears you can access the My Cloud Dashboard. If so you can access the My Cloud locally using Windows File Explorer or Mac Finder. If Windows File Explorer doesn’t see the My Cloud, then check Windows and ensure SMB1.0/CIFS is enabled. Microsoft disables this option in recent updates to Windows 10.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155

It appears you have some alert/notification messages. You should access the My Cloud Dashboard and view those alerts/notifications by selecting the alert/notification icon: mycloudnotificationicon

Generally the My Cloud Dashboard > Settings > Cloud Access section should indicate some form of connection status or a failed connection statuts. Your does not appear to be doing either for some reason. An example showing the a connection status.

Screenshot_2020-09-02 WD My Cloud

One can try turning off Cloud Access wait a while then re-enable it and see if it indicates a connection or failure to connect.

Its a Windows 10 issue. Download Advanced IP scanner. Run it and look for the IP address of your NAS. Then go to “This PC” and"map network drive".

1- What specific My Cloud model do you have?
i have the 4tb Single bay version
WDBCTL0040HWT-EESN ( i cant find if it the first or second generation )
Firmware : 2.31.195
Just update it to : 2.31.204
When i check for updates i get this

The Enable SMB 1.0/CIFS solved the local connection …Thanks for that =D

about the Cloud Access :

In the pics here i turned off the cloud


i kept it that way till :

it dont take time like connecting or something it get ( Connection Status
Ready) right away

For Cloud Access, I’ve never seen “Ready”. Usually it will say:

  1. Port forwarding established (best)
  2. Relay connection established (good but not great)
  3. Failed

Update the firmware manually and see what happens.

that is why i cant find any help in other topics =D

how i do update manual ? if there is any link to show me how i will be so thankful =D

Go to this page and download firmware file 2.31.204:

https://support-en.wd.com/app/products/product-detail/p/126#WD_downloads

The go to your dashboard, Settings, Firmware, Update manually

done updating same Ready to connect

I too have never seen a My Cloud indicate: “Ready Cloud access is now available from your device”. Or seen anyone post a screen shot saying this.

Couple of things to check. Make sure the My Cloud is connected to a router that has an internet connection and check the router to ensure it’s not somehow blocking or filtering the My Cloud from being able to access the Internet.

If using a Pi-Hole or similar device that is filtering URL/DNS requests disable it temporarily and then cycle the Cloud Services button to see if it indicates a connection status.

Make sure the correct time zone has been selected in the My Cloud Dashboard > Settings and that it indicates a correct time.

Click on the Configure>> option under Cloud Access and make sure it’s set to Auto then hit the save button.

about the time it wasn’t setup to the correct time so i did it manually

about the router i have tp link TD-W9960 iam already have 2 PC,s and ps4 and the My cloud
as lane connection and all the devices work perfect ex the cloud

and about the Cloud Access Connection Option it is Auto

that thing that make me mad that it dont try to connect it give me Ready in the same secound the t turn the option on

i checked the router no filler at all the option is not even on

it could be something wrong here ?

For testing i try to turn the router on with out the isp wire so the router dont have internet at all but it is working as local connection
and i checked the Cloud option i got thins
Screenshot (43)
then when i connect the ISP wire again it changes for Ready the second that the router internet connect the internet

Well, at this point, you may want to try changing the port forwarding settings. See if your router has UPNP switched on and what ports are open.

I recently had an issue where a MyCloud had messed up time settings. It was off by several hours. . .and I think I got the “ready” indication you describe. Certainly, the machine wasn’t talking to the WD servers like it should have.

Fixing the time (I enabled the “auto” function) fixed the problem, and the machine connected quickly afterwords.

Screenshot (44)

the time setting up was so good
but now we in Connected (Relay connection established)

how can we make it the best Port forwarding established (best)

You change the setting from Auto to Manual by selecting the Configure link in your screen capture and proceed to setup the two ports for port forwarding. Then you setup port forwarding rules within your router to match the external port numbers you configured in the My Cloud.

There is another post made yesterday in this same subforum (My Cloud) that explains in general terms, on a first gen single bay My Cloud, how to enable/setup port forwarding for the My Cloud - Cloud Access service. The process may be relatively similar for the second gen v2.x single bay My Cloud but I don’t have access to a v2.x unit to check.