Please help -24hrs of trying and cannot connect to http://mybooklive


#1

So far this has been the least seamless pnp product I’ve ever had the misfortune to encounter.

Try as I might I cannot get any computer on the network to connect to mybooklive dashboard. I have cable internet, connected to a router, connected to an airport. I can see the mybook drive and the public folders on two windows 7 pc’s on the wireless network, and also on an XP desktop. The installation CD and software will not function on any of the three pc’s, it does not find the drive on the XP machine at all (even though I can see it and read to and write from it in explorer), and on the windows 7 machines, it finds the drive but then times out at the install stage. 

Anyway, that’s not so important. What I need to be able to do is get into the dashboard and create some sort of network security and control the settings on the drive.

IE on the XP machine  just times out. 

Google chrome on the windows 7 machind also times out with this:The webpage at  http://mybooklive/  might be temporarily down or it may have moved permanently to a new web address.

FIrefox on the windows 7 machine inexplicably defaults to some nonsense cash/credit advance site with the unfortunately similar moniker www.mybooklive.com.

I’ve tried this over the wifi, and now I’ve got the laptop connected by ethernet cable directly to the airport. I can still see the drive in explorer but I cannot get into the dashboard to make any setup changes.


#2

What you’re describing sounds like DNS problems in your network.

Try connecting this way instead:

http://[ip address of your mbl]

example:   http://10.0.0.15/

If that works, you need to make sure your DNS Server is getting updated with the Name / IP address.


#3

I did that and it has worked thank you very, very much.

I have another issue now if you could address it for me please.

I have set up other share folders and made them private. When I log out of dashboard however and try and actually access the folders with the correct username and password, I get the same error :

"You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Multiple connections  to a server or shared resource by the same user, using more than one username, are not allowed. Disconnect all previous connections to the server or shared resource and try again"

What am I doing wrong? I am the administrator, I cannot get in with admin username and password, nor can I access with other usernames and passwords - as far as I can tell, I have the folder set up correctly in the dashboard - it’s private buy with read and write privileges ticked correctly


#4

Due to a Windows limitation,  ALL shares that you expect to be concurrently accessible from the Windows Box by any specific windows user *MUST* have the same User ID and Password on the network storage.

So if you open a CMD window and issue the command

net use /delete

that will close ALL connections to ALL Network Storage locations and will allow you to log on using the new User ID and password.


#5

Ok. Any chance you could explain that to me, or run me through it, like I’m the proverbial 4 year old.

I tried that cmd - is the syntax correct there? - “netuse/delete” ?

It didn’t make any difference to the access.

Right now what I have is the standard public folder, which everyone can see.

I also have a second folder for which :

-Share access is “private”. 

-Under username I have “admin” and it’s ticked for share access and the circle is dotted for full access, read and write. 

-Under user list and user detail, “admin” is ticked and circled for access to both the public folder and the private folder.

I can access the public folder but I cannot access the private one. If I make the private folder “public” then I can access it.

If I go into explorer right now and click on the private folder right now it gives me the following :

“Windows cannot access  mybooklive/folder. You do not have permission to access mybooklive/folder. COntact your network administrator to request access.”

Am I not the network administrator? It’s my house, it’s my laptop, and I bought and paid for the jaysus mybooklive and set up the folder?!

Any advice greatly appreciated.


#6

When you log into your computer, you have a user name and password. Say, WDBloke, and pass1 for the sake of argument.

On the My Book Live, you’ve set admin, and a password. Say, WDpassword.

If the usernames don’t match, which WDBloke and admin don’t, or the passwords don’t match, which pass1 and WDpassword don’t, you can’t access the share because it isn’t yours.

This frankly retarded behaviour is just another useful windows feature.

If your usename for your computer happens to be admin (which is possible, if unusual) then you need to make sure the passwords match. This means every computer you want to access the share needs the same username and password, and possibly need to access it one at a time.

I’ve given up on dealing with this behaviour and just use read only public shares, copying data to the drive without using windows shares (I use rsync over ssh). Good luck

edit: I’d spelled “match” as “make” :frowning:


#7

Thanks jonj678. Much appreciated. I’ll give it a go. 


#8

I had the same problem. I assume you have windows xp. I have found a workaround that works for me. I hope it’ll work for you. Do you have your network folders mapped (do they show up under My Computer as drives)? I have two folders one is Public and the other one is Private which is only accessible by the user ‘admin’. Public is mapped as Y: and Private is mapped as Z: . If you have mapped folders note the drive letter for each so you can use the same drive letters in STEP 2. If you don’t have mapped network folders omit STEP 2. STEP 1: Whenever I get the error message you mentioned I go to Start>Run… type cmd hit OK. At the command prompt type ’ net use * /delete ’ without quotes and hit enter (note the asterisk). It will show all the connected drives and ask to disconnect them. Press Y and enter. Then you get conformation that the drives were disconnected. Close the cmd window. STEP 2: Go to My Computer and look for your mapped drives. Public Y: is disappeared but Private Z: is still there (that’s what I get). Now using the Tools menu in My Computer window select Map Network Drive… For Drive: select Z: and for Folder: enter \Mybooklive\Private (or use the IP number instead of Mybooklive). Hit Finish. Then enter the user name admin and the password. Repeat the same for Public folder. Tools>Map Network Drive… For Drive: select Y: and for Folder: enter \Mybooklive\Public (or use the IP number instead of Mybooklive). Hit Finish. This time you won’t be asked for login info since it’s a public folder. Now you should be done. Check whether you can access the folders. Unfortunately this is not a permanent solution. You will have to do this every time you get the error. Usually happens after an improper disconnection like a crash/restart. On a different note, make sure you disable media serving for private folders from the dashboard to make them truly private. Let me know whether it worked.  p.s. I think after STEP 1, mapping the private folder before the public one might be the key.