Player & Remote Freezing

Hi, I’ve been using this for the past 2 years now and I really love it.
Prefer more than my Apple TV, and I use this almost everyday.
But recently I’ve been facing issues with the freezing.
I was on the latest F/W for quite some time already.

First it was the remote, I had to manually force the power by unplug and plugging to start up the player.
I’ve changed the remote batteries many times but did not help.
At the same time I was also facing my player freezing during playing my media files which was very annoying.
I tried a S/W reset from the setup menu but this did not help.

I searched and searched the web and found this community and found out that I wasn’t the only one facing this issue. I found out that most were solved by F/W downgrade and changing some config on the network settings. This did not help for me.

So I decided to upgrade back to the latest version instead, but again no luck.
It was time I decided to gave up and buy something else, maybe like the Amazon Fire TV.
Then suddenly I came up with some idea and decided to give it a last shot.
The idea was from my routers. I remember when after upgrading the F/W for the routers they would require a H/W resetting with the button from the device. So I did the same to my WDTV.

So far for the past few days, both remote & player freezing is gone!
I will need to monitor longer and hope this works, or else I’m really trying to get something else.

Hi there,

Good to know the unit is working properly after the reset, hopefully this can help other users on the community.

so rest the router not the width ?

Hi, no I did not touch the router or the width.

Here is what I did.

Downgrade F/W->Upgrade F/W->H/W Reset(button is located under the player).

Hope so, so far for the past few days it’s fine.

I was able to use my remote properly and watched 2 movie clips straight.

Had the same problem, freezing after 30m or so with some mkv’s playing from an external WD 3TB. Had to unplug power to get it working again. But after restart and skipping the movie to the point were it froze, it froze again after 10 or 15m. Did a FW downgrade as mentioned in other posts, and after downgrade a factory reset from the menu. Wached the same movie again and no more freezes. Don’t know if it was the FW downgrade or reset, but for now it works again like it should. Firmware downgrade: WD TV LIVE image freezes and does not respond

Freezing: subtitels dissapear, movie starts to stutter, movie goes in fast forward, then freezes all together. Remote doesn’t respond, app doesn’t either.

Original FW: 2.02.32, rollback to 2.01.86

Steps: Factory reset from menu -> FW rollback -> Factory reset from menu.

Still connected to the internet, no problems there.