PiDrive Foundation Edition compability with Raspberry Pi Zero W

New PiDrive owner here. I just received them in the mail today and can’t get the PiDrive Foundation Edition 250 to boot with the Raspberry Pi Zero W that I have on hand. On startup with the provided microSD card I only see the rainbow colored splash screen. It shouldn’t be a low power issue as I’m using the (optional) WD 3 amp power kit. Since I ordered 2 of the PiDrives, I’ve swapped out all of the parts (microSD, cable, and drive) to insure that there wasn’t a hardware issue. I suspect that the kernel.img file on the provided microSD card hasn’t been updated to support the new Raspberry Pi Zero W. I downloaded the latest WD PiDrive Foundation Edition Software (10/11/2016) and updated one of the the microSD cards. Still get the rainbow screen.

Any suggestions?

Hi, I’m working on the Zero W now. We just recently received samples and it requires SW surgery. I hope to provide you an update later this weekend. Thanks.

Thank you for addressing this issue Dave. Hopefully it will not be too difficult to tweak the code for the Pi Zero W.


Hi Bill, I was able to create an updated version of Foundation Edition that supports Pi Zero W and CM3. Please consider this experimental- I’ve tested it briefly on Zero W and Pi3, but not on the other platforms yet. I built the Raspbian and Raspbian-Lite OS install files based on the latest stable releases which now have SSH disabled by default (for security; the change was made by the R-Pi Foundation). The OS install menu now has Raspbian PIXEL at the bottom of the menu (previously at the top)- following alphabetical order.

The files are at the Dropbox link below in a zipfile Download the file to your PC, then unzip directly to the root directory of a new or freshly-formatted sdcard (4GB or larger). 7-zip utility is recommended. If reformatting an sdcard, use SDFormatter utility with options Full Overwrite and Format Size Adjustment enabled. After unzipping to the sdcard, there should be 27 items in the root directory with no parent folder.

When you get a chance to try it out, let me know if you find any problems.


Link to zipfile:

Link to SDFormatter:

Link to 7-zip:

Hey Dave,

Thank you for getting this together so quickly. I’m downloading it now and will test shortly. I ordered a RPi3 the day I reported the issue with the Zero W and have been playing with the PiDrive on it since late last night. I ran into one issue on the Raspbian install when updating (sudo apt-get update) that I verified is not related to the PiDrive by using a fresh install of downloaded from

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

An easy fix is to delete the folder /var/lib/chksshpwd before running the update.

I’ll start testing on the Zero W (and likely the Rpi3 too) this evening on the experimental build. Unfortunately, I can’t help test on other Raspberry Pi devices as a gave away my half dozen gen 1 and 2 Raspberry Pi boards for furthering the new owners education. I’ll let you know if I run into any issues with the build.