Photos 1.1.1 on MyTouch - Unable to connect to WD Server

I’ve got a MyTouch with WD Photos 1.1.1. I have the WD World Edition (white lights) . Firmware 01.01.18 with MioNet I’ve never been able to get WD Photos to work. I’m able to log into MioNet within WD Photos, and it does display the name of my NAS device, so I know the login is working and the account at MioNet seems to be working. But when I click on my device within WD Photos on the MyTouch, I get the message “Unable to connect to WD server.”

Did you ever get an answer for this?

I have the same issue.  WD My Book Live 2TB - Firmware upgrade 2/3/2011. Mobile device Verizon/HTC Droid Incredible.  WD Photos 1.1.1.  MioNet service enabled on WDMBL.

I am able to login to MioNet from the Mobile device.  I can see the My Book Live with my unique name.  When I select the device, I receive the “Unable to connect to WD Server” message after 10 to 15 seconds.  I have attempted to connect with WD Photos over WiFi and 3G mobile.  Same result.  I installed the local copy of MioNet on my laptop - same result.  I can login to MioNet via the web and browse the folders containing photos.

This feature was a selling point for the WDMBL. 

Please try restarting the My Book Live. If you are able to see the drive Online in WD Photos after restarting the drive, please send me an IM with your E-Mail address. We will need to grab system logs from the drive to confirm the behavior you are seeing.

Laura,  I tried the reboot.  It did not correct the problem.  If you would let me know how to sned you the IM I would be happy to do so.

I’m having a simular problem. I solved the Unable to connect to WD Server by turning of my WiFi and connecting via 3.5G, web version of MioNet can’t connect remote from local network either.

Any port need to be open to run this? MioNet works with my current DMZ port forward settings.

When I’m in the screen with My Resources and when I click on my drive the screen seems to scroll right but it’s on my resources again and no sign of my data.

I’ve updated my firmware to 

Description NAS Firmware
Version 01.02.06 with MioNet
Last Upgrade Thu, 10 Mar 2011 13:06:50

In WD photo’s 1.1.1 I’ve cleared my cache, reconnected, clicked my device i then seen First time setup, screen scrolls right and I’m back on the screen I already was on.

What to do with an advertised function which doesn’t work. Time to say goodbye to my 5 WD Books and get a nice QNap NAS system which does do what it says in the specs.

Been a happy WD customer for 20 years now, ever since my first 213MB WB drive, but I think it’s time to look for an other brand which can live up to the promises.