Permanently Red LED on WD Cloud

#1

I have a My Cloud Nas drive and a few weeks ago it just went Red and was totally inaccessible via the IP that I was using. I have tried resetting it using the reset button but nothing works and the LED is still red constantly. I have a linux laptop and sata to usb cable. I just want to get my files off this now so where do I start? Should I use the controller to try and access it or go direct to the HD?
linux fdisk -l direct to the hard-drive doesn’t do anything. The WD Red disk doesn’t show up.

#2

If this is a gen1 mycloud, your data will be on partition 4.

If this is a gen2 mycloud, your data will be on partition 2.

They both use EXT4 file system.

I would attach it to the USB cable adapter, then check what gets stored in dmesg. It could be your drive has totally died.

#3

I have attached the drive to a usb-sata cable but can’t get the drive to show up. Im not a linux expert by any means so what commands do I need to run to check the drive is contactable and readable?

#4

fdisk -l should show all connected drives.

#5

tried that…the HD doesn’t show up

#6

Either the USB adapter is not working or the disk drive is not working. This may be a dumb question but you did take the drive out of the My Cloud case?

#7

Yes…the HD is now out of the case. You have to do this access the Sata connector

#8

when you connect and power up the drive, does it spin up?

Does it make any odd noises?

#9

Hi, new here and sorry to jump on your thread but I have got the dreaded red light also.

We recently shifted all our data equipment to a ‘hub’ and consequently the my cloud drive was shifted also. Once shifted it was showing a red light and I assumed it was due to the fact that it wasn’t connected to the network properly. It is connected the way it was before but when it powers up it makes a few clunky/clicky noises while it shows an orange light and then it eventually goes red and cannot be seen on the network. I have tried the 4 sec reset and the 40 sec reset but it still has a red light. Although if the 40 sec reset worked I’m not sure how to go about setting it up again. I have tried to connect it directly to my PC and the lan light comes on but I’m not sure how to connect to it from there (if at all possible).

Is anyone able to shed some light on this for me? Thanks