Pending (Drive Not Accessible) error - SOLUTION :)

It seems I’m not the only person who had this issue with the software losing the drive path information - the solution just requires an XML editor.

  1. Quit WD Anywhere Backup - right click on the icon in the task bar
  2. Go to C:/Users//AppData/Roaming/WD/WDAnywhereBackup/instances
  3. In there you’ll find the folders containing each of your backup plans
  4. Open the XML document in there using an XML editor (I used XML Marker - simple to use and free from )
  5. You’ll see a line in there saying “”
  6. Change the ‘unknown xx-xx-xx-xx.lan’ to the name of your drive - Use WD Discovery to remind you if you don’t know.  It’s the name in the left column
  7. Save the XML
  8. Do the same for the XML file in C:/ProgramData/MemeoCommon/autobackup
  9. Restart WD Anywhere Backup and it should be working again

Not sure if this is a permanent fix but I’ve just tried it and it seems to be working so far!


I think I am having this same error.  

If I unplug my drive (power) my Dell (Vista) wont find the drive when I plug it back in.  Although my wifes toshiba running Vista doesnt seem to have a problem at all.

I just get the pending error I have to remap the drive, and then create a new back up plan. 

Is that what this solution fixes?   Sorry if I am an ■■■■■.

Excellent post, thanks. It resolved my problem.

Suggestion for your solution;

  1. You will only be able to see the AppData folder if you; Open Windows Explorer, Tools, Folder Options, View, Click “Show hidden files, folders and drives”. After you have done your tinkering I would suggest unticking. Just to be safe.

  2. I never used any fancy .XML text editor. With MS Windows 7 (Home) I just right clicked and opened with “Notepad”. Worked just fine.

Kind Regards

This looked SO promising. I was so excited to find this post. However, when following the steps unfortunately WD Discovery can’t recognise my drive. In fact, in Explorer all of my drives X and Z have a red cross through them.

MyBookWorld drive - the white light on the front has disappeared. Once I unplug and reconnect the light comes on for a few minutes and then goes off again.

I’ve tried looking in McAfee to see if the device was viewed as an intruder - NO. I’ve tried looking in my router settings to see if the device’s address was banned - NO. 

I’m completely at a loss as to what to do. 

I REALLY hope you can help - lots of backup files in there that have been deleted off my C:\ and stored in the back up without physically backing them up on an external USB drive.  Aaarrgghhh.

Have plugged my laptop into my bthomehub router - that seems to have given me access to the drive.  However in WD Anywhere Backup I’m still getting the error message “Pending (Destination not available)”.  I’ve tried as you’ve suggested to edit the XML script - but I’m not sure what to insert here <Key Name=“dest” Value=" [\Unknown-00-90-a9-6f-d7-4c.home\Public\My](file://%5C%5CUnknown-00-90-a9-6f-d7-4c.home%5CPublic%5CMy) WD_Backup" />  - Ihope someone can help - going a little crazy here…

Note: in WD Discovery - Network Drives Found = “MyBookWorld” - not a numerical location - perhaps I should insert the IP address?

I, too, thought it sounded promising, but my WD software remains oblivious to the drive for backing up files.  Those which were there can still be seen, but no further backups - since 5 Oct when I installed it.

Try using this network scanner It’s free - download and save to your desktop. The WD Discovery tool fails on many occasions to discover anything! Map your network drives using this download - follow the instructions on the website. I also set the IP of my MBWE to a static one, which seems to be more stable.