Password Protection for the internal HD Share is not working eg. ignored

There is a Option to set a Password for the WD TV LIVE HUB Shares, i set an Username and Password there, but can still Access it without Username Password. I real Security Threat if you don’t know!

The Newest Firmware is flashed and turning on/off does not solve the Problem.

You say turning on/off doesn’t fix.   Did you actually RESTART IT, or just put it in standby?

You have to restart the hub in order to see the change from the system menu or shut it completely down.

Set it more than one Time and switched the Device off more that one Time, it is ignored, i get into the Share without to be prompted for any Username/Password, i even changes the Username/Password between, nothing changes…

I can’t reproduce this…

In fact, I didn’t have to power off as I originally thought…

As soon as I put Login Protection to ON and set the UserID and Password, my open window to that share then asked me for the User ID and Password when I tried to open the file…

Well, here it does not seem to work, i defined it more that one time in the GUI saved it and tried with and without switching off and on, it goes straight trough without any password Prompt from the w2k Notebook, not tested with the other XP and w7 Machines, but don’t see why it should not work with w2k and with others, no Prompt is no Prompt…

Tryed again the PW-Protection but it does not work, however i got it to present an Password prompt after some sets and reboots, but then it will not accept my Password and sometimes a Prompt without Username appears where Guest is default and greyed out, still the Password is not accepted then, doesn’t matter if empty or the correct one… If i disable it again, everything is fine and i can open the Share, but if i enable it, it ignores the Settings or also present a wrong Prompt without Username or one that seems ok, but never accepts the Password or the Username/Password, really strange, this Feature looks pretty **bleep**ed up for me…

What is presenting the wrong prompt?    The WD can’t tell your PC what prompt to provide…

What else as the Hub if i try to connect to the Hub’s IP?

A Prompt where the Username is greyed and has an default Username “WDTVLiveHub/Guest” is wrong for me if i have specified an Username in the Hub!

And like i said, there was also a normal Prompt with Username and Password, but it doesn’t matter which ones comes, the Username and/or Password was never accepted, but as soon as i disable it it works without.

Also sometimes i set it enabled and reboot the Hub and no Prompt at all comes…

Its very random and crappy…

The other Thing watched while set up the Username and Password in the Hub itself with the Remote is, sometimes while selecting the Chars, it drops out to the Menu and i have to start over again, but seems to be another Bug that happens on other Places too where i have to enter something like YouTube, it simply drops out to the Menu while selecting the Chars, very very annoying!!!

I don’t think you’re understanding my question, or I’m not understanding what you’re saying.  :)

When you open up a Windows File Browser window and put \wdtvlivehub\

in the address bar, what happens?

On mine, it just pops up an authentication box.

scrape1.png

  I provide the same User ID and Password that I configured on the hub…

scrape2.png

and I’m in.

scrape3.png

I don’t understand how yours is saying WDTVLIVEHUB\GUEST unless you’ve got your computer configured wrong, because SAMBA Authentication Challenge does NOT provide a USER-ID to put in there, the User ID is being provided by your computer.

Its the same Box that pops up, but sometimes has “WDTVLIVEHUB\GUEST” in the Username Field(Upperfield), that is locked and greyed out, the other Box looks the same as yours(except upper is Username and lower is Password), but entering the correct Username and correct Password(the one set in the Menu of theHub with my Remote) does not log me in, says its wrong or also what is very silly, says i’m allready connected with another Name, what is not the case (double checked and even disconnected and droped all connections). I tryed many Times even with very short ones like “a”,“a” because being dropped out to the Menu while entering longer ones all the Time, no way, never worked.> So its disabled now, then i can connect the Netdrive.> Also there is one difference between yours and me doing , i use the IP of the Hub like \1.1.1.1\WDTVLiveHub and also i make a NetDrive, but this should not matter…> Anyway, don’t thnk i will use the Hub’s HDD, too slow, too dangerous, so does not really matter for my, but whatever causing this Bug, perhaps it will be fixed in one of the Firmware, if not i don’t care anymore, i have enough Storage.

…says its wrong or also what is very silly, says i’m allready connected with another Name

ALL of this is the bahavior of your COMPUTER, not the HUB.

The Hub doesn’t care how many users are attached to it.    Your computer DOES.

Hehehe, yeahh and i have here, wait, 6 different Machines with w2k, winxp, win7, w2kserver and i tryed with 3 of them, it does not work, yes probably all 3 have the same Problem also even if freshly booted, but can connect to ALL other Devices here wait 13 different ones without Problems, only the Hub causing this Problem, yeahh its not the Hub, it must be the Computers or Windows that is faulty… Forget it!

The fact remains.   The error message that says you cannot log on with a different user name is a WINDOWS LIMITATION, not a HUB limitation.

You can try this hail Mary pass:

NET USE * /DELETE

That will purge ALL CONNECTIONS.

Yeah, i know that too, but there was non while this Message came, so its a bit strange.

Also if that Message don’t came, i’m still not being able to login with the correct Username/Password,

who knows perhaps the Hub acts different with connecting Netdrives and simply opening the Share, i don’t

checked that because i commonly use Netdrives only.

But anyway, i disabled it now and will not enable it again until a new Firmware comes, then i will try it again.

I will not use the internal HDD anyway also, its too slow and well the Hub should use it for his Stuff like the Medialib, Backdrops, Pictures, Themes what ever,  i don’t care.

The really important Fix i wait for is the HDMI-Standby-Bug, because its annoying to shutdown the Hub each Time completly only because the HDMI is not switched off. Also the Resolution-Bug is important too for me, the others are minor important currently, well hopefully these two will be fixed in the next Firmware, and who knows perhaps some minor Bugs too… :wink: