Password Protected WD My Passport inaccessible

Hi All,

I searched the forums but couldn’t find a solution for my issue. My WD My Passport was protected with a password through the WD protection utility software in the disk. It was working fine until I plugged it in now, LED light turns on and I can feel the disk spinning (with a couple of very low click sounds) but the password inout application pop-up isn’t coming. The WD ROM drive icon in My Computer is just a generic Disk Drive icon with a Letter now and when I double click it, it says please enter disk. The HD drive used to appear above when I had entered the password so now naturally it does not appear, rendering my HD inaccessible. Any solutions?

Hello,

Did you make any changes to your computer?

As a recommendation, download the WD Security app from the WD support site and install that on the computer again to see if you can unlock the drive.

Link to app:

basic debugging: use on another computer and report

I did try that. Tried it on 2 different laptops. Same result.

I didn’t make any changes. I tried it on 2 different laptops but it’s the same. The wd security ROM icon that appeared on my computer when ever I plugged the drive in is now just a normal landed disk ROM icon which is empty.