Passport Ultra & WD Drive Utilities


Received a Passport Ultra 2TB for Christmas. After installing the WD Drive Utilities software that came with the Passport Ultra my two existing MY BOOK external drives were not recognised by My Computer. I have since uninstalled the WD Drive Utilities software, disconnected and reconnected both external drives and they are now recognised by MY Computer.

Is there anything I should do before trying to reconnect the Passport Ultra?

Thanks in advance.

Hello and welcome to the Community.

If you unplug the drives and then install the utilities, do you experience the same? If you haven’t try that, please do so.

What you experienced is not normal. I haven’t seen that before.

1 Like

Thanks for the suggestion. I won’t be able to try for a couple of days. Will post what the results are.

I tried your suggestion and it has worked.

Have connected / disconnected the Passport a few times and the two My Book Drives are still recognised.

Thanks for your help.