Passport suddenly not being recognized on Mac after using on PS4 (URGENT)

I’m so scared that I ■■■■■■ up my drive after using it on my ps4 to save some data.

I used this drive on my mac for a few months now. I produce music in my freetime and do video editing so I stored my music and videos on my file. Recently I started playing my ps4 again since it was summer break, and bought some new games, I needed space for them and didnt want to buy another drive for my ps4 so i thought, why not use the drive I already have?

So I did, and I downloaded some of my game files from my ps4 onto the passport and all was fine.

A day later I need to access my drive again on my mac, but when I plug it in, it says “the disc you inserted was not readable” and I tried again and again but didnt want to tinker too much and accidentally delete my data.

In summary:
-Passport worked fine with mac for a while
-Used passport on ps4 to download a couple of save files
-Passport doesn’t work on mac anymore.

My issue is very time sensitive! I need my passport to work ASAP so that I can download data from a school email that will be deleted in 5 days from now