Passport showing as an Initio Default Controller


#1

Hey Everyone

I’ve had my passport for a while now (think if I remember rightly its a 250gb one) used it first on a Mac Powerbook G4  as my itunes folder became too big for the hard disk on it (unfortunately when I lent it to family it had its power cable snapped inside it and in these times of belt tightening with apple prices I can’t afford to get it fixed!!) and have since a few months ago used it to get some files off a Windows XP running PC for my family.

Tonight I found a major problem I’ve got a new PC (well new to me its a cast off from an uncle a bit retro by 2011 standards as its got an AMD duron processor, a voodoo graphics card, along with a soundblaster 1024!! But it suits me fine for what I’m using it for (flightsim, net browsing and hopefully itunes updating should I get my passport working!!)  so tonight I plugged it in and it came on as above an ‘Initio Default Controller’

It runs XP by the way so I thought it would have just plugged and played

Is there an easy fix for it or do I have now an expensive paperweight

Thanks in advance!!

Roo


#2

HI there, try to check if the drivers (If  you have a Smartware Passport) are installed correctly under that XP computer as well as checking the drivers for the USB ports themselves… Also try the older computer to check if the problem is the new computer or the drive.

That’s what I would do.


#3

I am having this problem as well.

I just got this drive yesterday, I ran through the installs for the WD Smartdrive stuff and assigned a password for my encryption.

I clicked update inside the Smart Drive, downloaded the update, ran the install, it restarted my system and the update had not been installed and the HDD no longer shows up.

The drive keeps installing the Initio Default Controller. I’ve tried it on another computer and it does the same thing.

I’ve tried manually picking the latest SES drivers that I downloaded from the website, but they do not work.

The drive does not show up in Disk management, so I can’t reformat it.

I’ve spent about 7 hours looking on the internet for solutions, the only ones that seemed to have fixes are unrelated flukes of usb power.


#4

Hi thepizzamatrix

I’ve checked for the USB port drivers and tried the driver link you put on but to no avail and unfortunately the old computer is no longer useable

Thanks for the help though

Roo


#5

Hi Brighton

I have too seen about the power flukes but connected my drive up to one of my main USB ports on the back of my PC as one of the post said it needed direct power from the motherboard but I did see something about AMD chipsetted machines having a different reaction to a WD passport and that they see them as an initio default controller!!

Hope that might have helped

Roo


#6

I would try a different USB cable, and also try to update the firmware on the drive as well.

http://www.wdc.com/wdproducts/wdsmartwareupdate/firmware.asp?id=wdfGeneric&os=win


#7

Inside the enclosure is a USB-SATA bridge board. In some models the bridge IC is integrated onto the drive. When the enclosure identifies itself as an “Initio default controller”, this means that the firmware on the bridge board is corrupt. I believe the solution is as simple as applying the “Apollo” firmware update.

See this thread:
http://community.wdc.com/t5/My-Book-for-PC/External-HD-to-Internal-HD-after-firmware-failure/m-p/160260#M5656