Passport Essential SE not recognized

I have a unique situation.

I just purchased a “My Passport Essential SE” 1TB. 

I plugged it into my desktop USB and it tells me it’s locating the device driver.  After a few seconds, it says that it is ready for use but I cannot find it through “My Computer” or “Disk Management”.  My desktop is Windows Vista 32-bit.

I then plugged it into my laptop, same operating system and it works fine.  I also took it to work and plugged it into my XP desktop and it worked fine as well. 

Any thoughs because I am VERY perplexed at this one.

Thank you in advance for any help,


It sounds like a power issue a lot of PCs use barely adequet power supplies. Did you try different ports on the troublesome PC? Also try unplugging all unneeded USB devices. They do make a power boost cable for these drives, it uses 2 usb ports on PC,


Thank you for the response Joe.  I have tried all available ports (3 different ones).  I have also attached other WD externals I own and they work fine.

I was not aware of the power booster.  I will have to locate one.

Thank you.

I know it’s on the WD site but I cannot find it. Try calling customer service.