Passport Elite 500G - USB Device Not Recognized...malfunctioned

My WD Passport Elite 500G (WD500MLC-00) has been acting up recently.  Today it stopped working totally!

I keep getting “USB Device Not Recognized - One of the USB devices attached to this computer has malfunctioned, and window does not recognize it.  For assistance in this problem, click this message.”

When I click on that pop up, it shows up as “Unknown Device”.

The light on the passport did light up, but the Passport Elite drive was still not recognized by the PC.

I seems to imply the device is “missing driver”.  Hence I went to the Western Digital website to download updated software for WD Passport.

I went through the “EssentialElite_FirmwareUpdater_v2.010(” and the “”.  Followed their 2-step process.  It still does not work.   It gave me the same error message.

I tried straighten up the USB cord, or hold both sides (connection to PC and the Passport) really firm.  They did not work.  (It worked before last week.)

I tried using another longer USB cable, this time the light on the Passport Elite did not even light up.  You can hear the click-click sound from the Passport Elite, sounded like something was spinning.


Same here and, unfortunately, no positive solution.

Reinstalling the software doesn’t seem to be the solution as you need to have the device recognized for the update to be installed on it (firmware).

I’m using Passport Elite 500G on a laptop running Windows and, since I bought the disk 4 months ago, had blue screens (physical dumps) when disconnecting the device even while using the “Safely remove hardware” utility.

Afterwards, I got this “USB drive not recognized” intermittently but almost all the time now, even after trying on 2 other computers (one Windows desktop and one Mac).

By chance, I was able to “see” the disk again after about 20 attempts this morning, only to get the blue screen 10 seconds later before I could save/retrieve my backup.

Bottom line, I’m stuck like you… Which is pretty frustrating for a backup solution, **bleep**!

One more thing. I wonder if the issue isn’t with the cable. Trying with a longer one as you did doesn’t seem to be a god option. Indeed, as it says on the WD support website, the driver my not get enough power then, hence the clicks.

The problem is that I don’t have other cables like this one and I left my docking base at work, so I’ll try tomorrow.

Why I’m suspecting the cable is that there seems to be some loose connection on the computer end (connection message coming up while just touching the USB plug).

If these drives are USB powered it may be a power supply issue. Did you try different ports on the PC? I think WD has a power boost cable, it plugs into 2 ports on the PC.


Thanks, Joe.

  1. Yes, I have three USB ports on my laptop and have tried them all, as well as 4 USB ports on my desktop, for the same negative result.

  2. I have other devices (DVD R/W, external drive) with dual cables for additional power, but the 500G didn’t come with the equivalent.


Good news (at least for me), I was able to mount the disk again using the docking. Although the cable is much longer, it is larger so maybe there is a power issue with the short one. As for the USB plug, sound like the same, but didn’t experience the lose connection that I did with the short cable.

I am having the same trouble. I have tried several different computers and the same messege comes up on all: USB Device Not Recognized.

I have tried moving the cord around etc to no avail.

Does anyone know if I can just get the information off the device? I don’t care too much for the device but need the information ASAP!!