Passport drive extremely slow transfer, not recognized

i have a WD 500gb mypassprt usb 3.0 drive.
A few days back, i found that the speed of copying files was very slow, around 1 MBps in all my usb ports, 2.0 and 3.0. The problem remained even when i connected the drive to other computers.
i have the latest, updated drivers and smartware. I even tried reinstalling all of them.
Then, I used the WD quickformatter to format the drive. It detected the drive and tried to format it, but it said “format failed”.
Now when I connect my drive to the pc, it detects it as a removable disk, but it does not show anything in My Computer.

How do I get my drive working?

This happened once to me and it seems like the drive was not formatted properly, try formatting in Windows and test it with the Diagnostic Utility from WD if it is failing you will get an error msg and it will try to repair them or let you know if the drive needs to be replaced, you can find all this info in the KB on WD web site.

1 Like

thank you for the info. i reformatted it using windows and now the drive is recognized.

But the copy and read speed is still less than 1 MBps.

i ran the WD diagnostics and it gave me an error for quick test and extended test.

i tried repairing using the utility and it says it is unable to do so.

So, has the drive failed and should i apply for a replacement?

Its been only 6 months since i bought the drive and it is still under warranty.

Since it failed test I would see about getting a replacement.