Passport 1TB driver does not work

My Passport 1TB stopped working yesterday. I have an identical drive and that one works fine.  I’ve switches cables and usb ports, nothing. The light blinks and the drive itself spins as normal.

This is the message I get after updating with the WD SES Driver

It moved from “other devices” to where its suppose to be but windows still can’t load the driver.  Driver version is the same as the other working 2.  Doesn’t show up on Disk Management and I can’t even find it in BIOS.

I did a system restore under safe mode and that didn’t help either.

If this can’t be fixed is there a way to get the files out and reformat the drive? Any software suggestions?

WD My Passport 1TB

Windows 7 Pro 64bit

Installed WD SES Driver

Installed WD Smart Ware

Installed WD Fireware Updater

i have got the same problem,it is a great disappointment

I am also facing the same issue. On the top of this when i am going to “Update Device driver” it throws “Access denied” error.

I am using Sony Vaio (C-35) Laptop.

Need help to resolve this issue!!

i have a problem with my passport 2tb dosent connect too laptop or pc even tried on friends pc and laptop very dissapointed

Past few days I’ve been searching the internet on any kind of fixes to this. Tried every suggestion I came across. WD contacted me back and said that my drive is defective so the only thing left to do is take it to a place that offers data recovery services.

Here are some of things that I have tried;

-From my first pic I was getting unknown devices with driver not being able to install. Found a software called, DriverPack Solutions. Found out that the unknown hardware with the missing driver was my usb port. After the updating the driver I didn’t see that any unknown device or any driver not installing. Didn’t fix the initial problem but fixed another issue.

-Click on Start --> In search box, type cmd. When it show “Command Prompt” in the search list, 
right-click on it and select the option “Open as administrator”. 
Open the command prompt and type the below commands 
set devmgr_show_nonpresent_devices=1 --> Press Enter 
start devmgmt.msc --> Press Enter 
“Device Manager” window will be opened. 
Now in the device manager, click on “View” --> Select “Show hidden devices” 

Now expand the nodes “Disk Drives” and “Universal serial bus controller” by clicking on “+” symbol. If you find any greyed entries --> Right click on it --> Select “Uninstall”. 

(By doing this with my other external hdds it shows the actual drive and a ghost of that same drive. i uninstalled the USB Mass storage ghost drives and any other ones related to the external drive.)

-Click on start --> run --> type regedt32 and click on OK. 
If you are using windows vista or 7 then click on Start --> In search box, type regedt32 and press Enter
First backup your registry by going to file --> export. At the left side navigate to this location 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E967-E325-11CE-BFC1-08002BE10318} 
If you see any upperfilter or lowerfilters at the right side delete it. 

(DO A SYSTEM RESTORE BEFORE TRYING THIS. After doing this and restart the comp and soon as the windows logo came up it did a restart on its own. After the restart, windows went into troubleshoot and I had to do an system restore. DO THIS AT YOUR OWN RISK)

After a close examination of the hard drive itself I noticed a click/clack noise at the 1 minute mark from plugging into the comp. Another click/clack noise 2 minutes in and the drive stopped spinning. The drive heads might have gone bad. I’ll be getting some torx screw drivers to see if thats the case.  Hoping the platter is not damaged.

well wd didnt even contact me about my hardrive i have sent them emails as of yet nothing back so i will spend my money on another brand of hardrive whats the point of a warranty if customer service **bleep** WD you have lost a customer