[PACKAGE] NZBGet for PR2100/PR4100


#1

About time to fill up that WD app store… Here’s NZBGet, the most efficient usenet downloader.
More info about NZBGet on the official website.

DOWNLOAD LINK

This installer will fetch the latest and greatest NZBGet (v19.1 now) from the official sources (using the manual install one-liner).
Other features:

  • configure, enable/disable and uninstall the app from the WD web interface.
  • nzbget daemon starts on machine reboot

TODO: setup default download folder to the P2P share (or whatever) in settings - paths

/shares/YourP2Pshare/nzbget

==> this means you should do this step yourself. (note: confirm changes at the bottom of the page)
If it doesn’t work, you’ll need SSH to find the full path of your shares.

Login: nzbget
Pw: tegbzn6789

Feel free to change this in settings - security
I also strongly recommend to get yourself a matching browser plugin
Chrome - Firefox

More tips for Plex users: [PACKAGE] NZBGet for PR2100/PR4100

Warning: this is an experimental installer that you may use at your own risk and legal responsibility.
Feel free to validate the install scripts in the source (nzbget_x.xx_src.tar.gz).


Sonarr, Sickrage, Nzbget, Sabnzbd for PR2100/4100
[APP] NZBGet various versions for firmware V4+ (02/2016)
#2

You are awesome for helping. I try to install this manually trough “apps” but it says it cannot install “this app”.


#3

Which device are you using? I only tested on a PR4100… It could be I need to make separate packages for PR2100… If so, let me know!


#4

Ha maybe thats it. Im using PR2100.


#5

I posted links for all PR and DL devices in the download link.


#6

Thanks! Ive got it installed. Though, when i press configure; a new window pop up, but it cannot connect to nzbget


#7

I added the default login / password to the install instructions :slight_smile:


#8

But where do i fill these in? :stuck_out_tongue:


#9

hmmm odd. I’ll have a look in incognito mode where this is going wrong.


#10

In Firefox and Chrome it seems to work fine… which browser do you use?
Did you disable javascript?
Otherwise just add :6789 to the url…

Example if your WD NAS web interface is at 192.168.0.101, go to 192.168.0.101:6789


#12

ive reinstalled. I got the login screen now!


#13

Cool beans. I’ll try to iron out whatever went wrong there.


#14

cool. so the only thing i need to change is settings -> paths -> “MainDir” into; /mnt/HD/HD_a2/P2P/nzbget


#15

Yes, that’s because samba doesn’t map the Nas_Prog directory.
Feel free to use any other share… e.g if you only have a Multimedia share

/mnt/HD/HD_a2/Multimedia/nzbget


#16

Happy that downloading is working. but,mmm cant figure out how to get the download folder to “Public”. using mac. Cant get to the upper folders…


#17

In the WD web UI, in the shares tab, click on the Public share.
For me, it’s located on Volume 1.

You may have to enable SSH and explore your /mnt directory to find your public share.
For me it’s just in /mnt/HD/HD_a2/Public …
You could use cyberduck to get the correct path.


#18

I give up for today. For me its also located on vol1. Started up ssh, logged in, but /mnt is permission denied. Installed Cyberduck but no luck there.

Anyway thanks alot! Got it running very stable, now only the last part for changing into right download path & categories…

ps: is it also possible to make a sabnzbd app? :wink:


#19

I’m exploring some docker setup / teardown scripts… sabnzbd should be easy when it’s done. Any software to download linux iso’s right?

Btw, use SFTP protocol in cyberduck and login as root.


#20

/home/root is all i see

+2 folders

/home
/squeezecenter


#21

What do you see here?

cd /mnt
ls