[PACKAGE] Entware, the ultimate repo with about 2000 packages

/opt/bin/opkg

When you login over ssh after installing entware, it will use the bundled /etc/profile with opkg in the PATH

Ah, in /opt/bin. Got it.

Thank you very much. I am happy to have found this thread. As I said, I’m rather disappointed with the support in the available apps. I think this is the answer I’ve been searching for.

Hello,

Is there a way to list outdated packages and update them automatically with Entware?
I ran /opt/bin/opkg update and it downloaded latest update list to the machine.

Best.

Google suggests this openwrt wiki

How can I upgrade the mycloud to python v3?

Are you going to release this for OS5?

2 Likes

Version 20.11.17 for OS5 available here: https://bintray.com/beta/#/tfl/wdpksrc/Entware?tab=overview

2 Likes

@Tfl, you put-up the most recent package for the DL2100 and the DL4100.

I hold my hands up that I’m still struggling to understand exactly how I could compile an apkg installer package.

After registering a developers account. the download link at the bottom of that pages does not seem to work and takes me to the beginning. I can’t download the OS3 SDK. (Have reported this to WD, but not holding hope for a reply.)

Does anyone here have the latest OS3 SDK that can be made available, somewhere.

Upgrading to OS5 parks all app data in /shares/Volume_1/.systemfile/OS3_Apps_Backup/
The entware root dir at /shares/Volume_1/entware however remains untouched.

The first installation of the OS5 version should probably maintain all installed packages (not sure of that).
Everything should remain the same as entware ships its own libs, so it’s independent from the OS. The newer kernel won’t have any impact.

So I guess it’s simply the case of taking a back-up of /shares/Volume_1/entware, reinstalling the entware 1.05, tweaking any scripts as necessary and making sure that the /shares/Volume_1/entware directory still there and enabling entware?

I’m in no hurry to upgrade to OS5. I’m trying to find out how best to back-up data from apps like Plex, etc so I can re-install and restore data backups and get it back to as it is now.

So, sorry if I’m a pain here @tfl, WD have decided to just start OS5 with no apps installed when OS5 is initialised and all apps that were installed in OS3 have to be re-installed and then app data and configurations copied back over from /shares/Volume_1/.systemfile/OS3_Apps_Backup/?

This upgrade from OS3 to OS5 appears to be quite involved regarding apps.

I know the upgrade will be inevitable as I guess at tome point WD will fully retire OS3, stop providing any updates and support and it’ll be; You may continue using OS3 at your own risk as there will be no support and mycloud.com for OS3 will be discontinued.

Sigh, I did try to use this entware package on OS v5.11.112 but it totally screwed up the system. I am thankful that I still do have access to ssh and gui though all the packages just throw random errors. No data lost. I uninstalled it but it is still stuck the system. I am hoping Full Factory Restore will get everything back to normal because I tried everything else. System restore, re-updating the latest firmware, etc.

Is there any rescue firmware to flash for my wd my cloud mirror gen2? I looked but couldn’t find any.

@Tfl , you’re going to have to move the Entware OS5 update somewhere else.

Is GitHub - Entware/Entware: Ultimate repo for embedded devices still valid for OS5?

1 Like

what do you mean by that?
I installed via gui with the bin file and I uninstalled the same way but it still remains in the system. How to completely uninstall or recover the stock ?

Update: Sorry I guess you weren’t replying to me ):

You are correct. :slight_smile:

Yesterday I’ve installed Entware. Same version as you. Hit a few very small bumps along the way, but it’s fully working again with Entware, but I am using a DL4100. I have no experience with the My Cloud Mirror Gen2.

What was wrong with your setup and how did you solve it? It might inspire me :slight_smile:

Just to clarify, after uninstalling,
in /usr/sbin/
apkg and apkg_favorite
remains

and after installing and app in this case (twonky):

root@WDMyCloudMirror usr # current firmware version:[5.11.112]
MIN firmware version:[3.10.111]
MAX firmware version:
split count:[3]
split count:[3]
split count:[0]
CurrFW > TargetFW
target fw is empty
*** WARNING : deprecated key derivation used.
Using -iter or -pbkdf2 would be better.
Device “egiga1” does not exist.
Starting /mnt/HD/HD_a2/Nas_Prog/twonky/twonkystarter … -appdata /mnt/HD/HD_a2/.twonkymedia �Vlogfile /mnt/HD/HD_a2/.twonkymedia/twonkymedia-log.txt
Daemonizing…
/usr/bin/twonky.sh: line 292: itune_tool: not found

Oh boy, thanks for spotting that.
Seems like I’ll have to dig a bit deeper into Github actions and do a full rollout in there…

1 Like

Only thing that kept failing was that one of the packages installed kept on dying on start-up. Ended up that a .lock file was present. Once I removed it the application started, but everything else worked. I removed some coreutils packages that are no no longer needed, but that was it really. the OS5 entware app installed. (I just lost everything on the NAS’s root home directory at /home/root, but not much got lost. I can leive with that inconvenience.

The WD upgrade from OS3 to OS5 DID NOT create a backup of all the OS3 apps. Only the OS3 directory was created and that was empty. Another inconvenience.

Unfortunately I don’t have experience with the WD Cloud Mirror. I believe that NAS uses a totally different internal architecture and setup.

One thing I did do. Before upgrading from OS3 to OS5 I went into the apps list and turned off all the third party apps. It’s something that WD recommends. Never caused a problem when just upgrading OS3, but that WD has done is a major change to the back-end of the NAS.

Hi

I am trying to get Enware installed on my PR4100 running on OS5.
I am getting the following error when trying to run the generic.sh shell script that I find on the Entware repo page:

Info: Basic packages installation…
Downloading http://bin.entware.net/x64-k3.2/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Installing entware-opt (227000-3) to root…
Collected errors:

  • verify_pkg_installable: Only have 0kb available on filesystem /opt, pkg entware-opt needs 3
  • opkg_install_cmd: Cannot install package entware-opt.

Using a df command, I can see that /dev/loop0/ is 100% full but besides that, the rests looks ok.
Any clues on how to proceed from here ?

Thanks !