Out of the box My Book Studio 2TB not accessible


I’ve read a heap of similar problems here but all seem to be related to this problem occuring after some time. My issue is straight out of the box.

I plugged the WD My Book 2TB into the power (Light came on all good)

Then plugged USB into a spare USB port (Cursur changed & windows installed drivers after recognosing new hardware, all good)

Opened windows explorer & the drive isn’t there.

Here a few things I’ve checked & done so far plus PC details.

Firstly this is a new addition to my WD drive fleet, I have a 500GB passport, a 1TB WD essentials USB3 & a My Book Essential 2TB USB3 all of which work fine on both my laptop & my PC.

I have tried several different cables

I have tried connecting it to my laptop but it does exactly the same thing

I can see the drive in the windows drive manager window

The thing simply doesn’t show up in windows explorer, pretty hard to transfer files to something that doesn’t exist!

The light is on, the cables have been confirmed good, windows blinks & beeps when it gets plugged in, the drive shows in drive manager why can’t I see it?

From what I’ve read here so far it appears to be a common problem but I’m yet to find the answer?

Any help is greatly appreciated.

PS - If your advice is to return it for a replacement then I will probably want to change it for another My Book Essential 2TB as the one I recently purchased before this WD My Book Studio works perfectly, I bought the studio because I hoped it might write a bit faster via firewire but I haven’t even had a chance to test that as I connected it via USB to start with & this is where I’m at.



UPDATE: I’ve just realised this drive is formatted for Mac!! **bleep**???

So what now? How do I format this drive in windows if I can’t see it?

You might think I’m pretty stupid here but the fact is the shop where I bought this drive has all the Mac drives seperate from the PC drives, plus all the other WD Mac compatible drives are packaged in yellow boxes not black like the one I bought!!

I don’t know what OS you are using. In Windows go into Disk Management and you can reformat it there or use a third party format tool.