Os5 reindexing

It has already taken a week but is still going. I cannot find the music on the server all the time. Though I can see the music files via the app, my LUMIN player just can find the music library. Very much regretted to update the os. It makes things worst and I will think twice whether to buy a new product from WD.

What WD Device do you own? What troubleshooting have you done? Have you rebooted all your devices?

My device is my cloud mirror gen 2. In the previous os3, everything works just fine. After updating to os5, the music server was gone. I thought that it might be the indexing in progress and therefore waited a week for it to finish. After completion, the music server still not worked. After searching for solutions, some mentioned that it required the app twonky to be installed. I tried and after rebooting, they music server is found.

It is the last thing to expect that the app twonky was made missing in os updating. WD should inform the users by a message, at least.

Thanks you for your assistance and it is much appreciated.