Optical Audio dissapears on Movies only - still fine for music - restart solves

Hi guys,

I have recently encountered a problem - intermittent at first but now happening al the time.

I use an optical cable to output sound from the hub to a samsung ‘theatre in a box’ hifi.

Music plays fine through the optical cable but all movies (VOBs, MKVs, MP4s) have no sound at all. If i turn the hub off completely (long power off) then it works again or if I change to play audio through HDMI i get sound.

Is it possibly a setting under Audio Setup -> Digital Pass Through via Optical??? Have tried ticking and unticking the various options under there but with no luck…

any help/advice appreciated…

I think it is possible that those options are affecting it.  If you click an audio format that your sound system does not support, and you play a video with that audio format, I think you will get no sound. For example, my receiver accepts DTS and Dolby Digital, but not AAC. If I click AAC, and try to play a video with AAC audio, I get no sound at all.  But if I unclick AAC, sound will play.  

(With HDMI, the capability can be automatically configured, but with optical digital you have to to match it up yourself. )  

  

If you don’t click an audio output type, and the video uses that audio format, I think the WD will convert it to something all systems can handle. 

Try unclicking all the boxes (uncheck AAC, Dolby DIgital, DTS & WMA Pro)  and see if you get any sound.  If you don’t then it’s some other problem.  But if you get some sound, then you need to check the boxes that match your system’s capabilities to get full benefit from it. 

Hope this helps

John

Thanks, this solved the problem. AAC not supported by my hifi but didn’t realize the hub would output a format that works if unchecked…makes sense now